Application starts in rdp but not in ica

Hello,

After instelling PSE450W2K3R06 on a XenApp Server 5 an application is crashing.
The application no longer works in the desktop and even as a published application.
The application does not give an error. Nothing to find in the eventviewer.

If the application is started you can see in Task Manager that the executable is open, but after a few seconds it's closed.
Several things have changed, but unfortunately no success.

1. Speed Screen off.
2. HKEY_LOCAL_MACHINE \ SOFTWARE \ Citrix \ CtxHook \ AppInit_DLLs \ Multiple Monitor Hook adjusted.

The application starts with a Splash Screen. I suspect therefore that Citrix uses a technique that is keeping the application to start.

The application works fine in RDP
If the hotfix is removed the application works fine in ICA and RDP.

Anyone have any ideas?

OS = Windows Server 2003 Enteprise x86
AngelolelAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike ThomasConsultantCommented:
If you think that the splash screen is causing the issue you can normally add a switch to the executable path "/nosplash" to disable it.........it depends onthet app though.
0
AngelolelAuthor Commented:
This is not possible for this application.
0
dnsguru44Commented:
Try lowering the resolution and display size of the application to 800 x 640 and make it 256 colors only.  The ica client will override this so make the same adjustments in the preferences section on the wi.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

AngelolelAuthor Commented:
Tried it, but no succes.
0
AngelolelAuthor Commented:
Does anyone have any ideas?
0
dnsguru44Commented:
How many servers are publishing this application?  Is it only one?  If you have more than one, do they all have the same hotfix?
0
AngelolelAuthor Commented:
Yep. All the same hotfix.
0
dnsguru44Commented:
Any reason you really want this hotfix?  I would suggest going with a lower hotfix.
0
AngelolelAuthor Commented:
It solves problems. Problems with a bluescreen on wdica.sys.
0
dnsguru44Commented:
Ok... might you have a vmware esxi server where you can bring up another citrix box for testing?  You should have at least one test server in it's own farm for testing such things as installing new hotfixes.  Also, make sure that windows update service is not running on your citrix servers as an update installed via windows could have caused this issue as well.  

The next step is a bit cumbersome but it's really the only available next step.

First, compare the windows updates that have been applied to the working server against the server that is having the issue.  See if there are any differences.
0
dnsguru44Commented:
Just to confirm, if you log into the console of this problem server and launch the application does it work?
0
compoohCommented:
I believe the issue is caused by a seamless flag.  I would suggest temporarily adding the regkey to disable all seamlessflags.  After a reboot, retest.  If the app works, ther's a flag causing this issue.  You will need to narrow down the specific flag and disable it.  There's a Citrix dic on how to do this:

http://support.citrix.com/article/CTX101644
0
compoohCommented:
Citrix doc not dic - dang iPhone
0
AngelolelAuthor Commented:
Unfortunately has not helped.
I removed XenApp 5.0 and installed Citrix Presentation Server 4.5 with HR05.
No blue screens anymore.
And the application works again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.