Fix for ViewSonic VA1912wb Display

VA1912wb flashes grey with thin white horiz line at turn on
then goes black.
Power led stays on (green) screen stays black
cant bring up menu or "no signal message"
If turn off/on will cycle same each time
Have changed both cords and tried other computer
with same result
Thanks for any help
           Bob
RobertMClarkAsked:
Who is Participating?
 
RobertMClarkConnect With a Mentor Author Commented:
Power Supply is dead
DAC-12M030A
caps check ok
replacement cost about $50
decided to junk it
0
 
fugtruckCommented:
If it happens on both computers and with different network cables then the monitor is most likely faulty.

Before giving up though, you could try making sure your video card drivers are up to date and installing the actual ViewSonic Monitor device drivers rather than the default Microsoft driver.  Doing those can help fix quirky display problems.
0
 
fugtruckCommented:
I meant with two different monitor cables, not network cables :)
0
 
RobertMClarkAuthor Commented:
Thanks
I have done all of those things.
If you cut the monitor cable
the menu and "no signal messsage"
should still appear.
I know the monitor is faulty, tyring to get a line
on how to fix it.
Did anyone diagnose and repair this problem ??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.