SMTP Outbound from Sharepoint Services

I have my smtp server set up exactly as outlined in the Admin Guide.  I tested smtp by opening a telnet connection and all is okay there it seems.  I configured the outgoing server in the Central Admin. page available under the 'Operations' tab.  Still, each time I attempt to set an alert, I get the error msg: "This virtual server is not configured to send email..."

The Admin. guide specifies that email is configured from the "Default Email Settings" link which I don't see.  My only visible link is under the 'Operations' tab.  Is this the problem and how do I get to 'Default Email' settings?

FYI: I have installed MOSS 3.0 in a test environment on Server 2003 Std x64.  I now understand that there's nothing to gained by this because if asp.net incompatibilities which force the application to run in 32bit mode anyway.

Am I better off reinstalling this on the 32 bit version and starting again?

DefianseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

itgrooveCommented:
Hey there,
64bit should have nothing to do with this. Stick with it, as it is the only way you'll do an inplace upgrade to 2010 anyways (by the way, you can download Foundation 2010 effective today so if you are starting out, go modern!).
1. You need to set your Outgoing email Server settings under Operations - sounds like you have done this
2. It is entirely possible though, that your particular web application doesn't have its "Web Application Outgoing E-Mail Settings" settings set under "Application Management".  check there, I bet it has invalid values.  Make sure you are configuring the correct web application by selecting it from the web application drop down list at the top right
0
DefianseAuthor Commented:
Hi Thanks very much for responding.
I've attached a graphic of the settings I have.  If I have done this wrong then it will be in the specification of the server name.  The DNS name is ssps01.mydomain.ca

SharePoint-Outgoing-server-setti.gif
0
DefianseAuthor Commented:
Sorry, hit the wrong button by mistake and never completed the last (ID:31876089) message...
...DNS name is SSPS01...  This is both the Sharepoint Server AND the SMTP server.  Anything wrongs here?
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

GeorgeGerguesCommented:
Defiance :

One of two things that you have problems with .

1- SMTP Relay on the same server : this should not the case with you , as you mentioned you have a succesful instalation of Sharepoint ,... Just make sure you have  the SMTP Service installed and running on your Service .

2- A Server firewall or network firewall that is causing this error , you can also check that with the following

do this from the command line.

telnet < any SMTP Server you know off >  25

that should bring up the server's  MX header.

if not, you will get a nasty error message from the server's TCP IP layer that would tell you what is reason.


Thank you and Good luck
0
DefianseAuthor Commented:
Hi,
If I understand (GeorgeGergues) correctly, since the SMTP server and the Sharepoint server are the same server, SMTP Relay should be turned off?
Tested firewall status and got a freindly message back so all seems okay here.

SMTP-Test.gif
0
DefianseAuthor Commented:
FYI.  I noticed that there's a bunch of email sitting in the 'queue' folder under inetpub.
One of the error messages: Unable to deliver message to the following recipients, due to being unable to connect successfully to the destination mail server.  
I would assume that the destination mail server would be the one hosting the recipient's address?
0
DefianseAuthor Commented:
I finally found the issue and this has now been resolved.
The problem was because our email is hosted by a third party and that server does not reside on our local (domain) network.  Recipients of other email domains were receiving but not ours.  I had to add the required information in the 'Smart Host' field under the [Advanced Delivery] section of the SMTP Virtual Server properties after which alerts to me@mycompanydomain.com came flying in to my inbox!
Thanks to everyone for trying to help.  I know that there wasn't enough information provided by me in the beginning to find a resolution which I apologise for!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.