Squirrelmail Postfix Allowed Memory error

I'm trying to access my email via squirrelmail but was given this eror:

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 19456 bytes) in /usr/share/squirrelmail/functions/decode/cp1252.php on line 94

The email is on a mailgateway setup with postfix, dovecot and squirrelmail installed.

I notice that only this particular address is having this problem. There are other addresses on this virtual domain, and they all work fine.

I'm guessing this has something to do with the size of the INBOX since I'm using this particular address for automatic backup.

So my questions are:
1. What causes this error?
2. How do I fix it?
3. If the problem is the size of INBOX, can I increase the allowable size? There are plenty of space in HDD.

Thank You
SW111Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hernst42Commented:
1) It's the memory_limit of PHP (16MB) Try to increase it.
2) change the php settings for memory_limit Read http://www.php.net/manual/en/configuration.php
3) does not apply due 1)
0
bevhostCommented:
edit this line in /etc/php.ini

memory_limit = 16M

you could try

memory_limit = 32M
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SW111Author Commented:
Hernst42: Thanks for the help and explanation. You pinpointed the problem and cause but the solution is a bit too much reading, given Bevhost's answer.

Bevhost: Thanks for the solution. Since Hernst42 pointed the cause, etc, so it'll be fair if we share. Btw, for Ubuntu users (such as myself), the path is:
#sudo nano /etc/php5/apache2/php.ini
then afterwards you have to reload apache2.

Thanks guys.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.