win 7 "because of a protocol error, this session will be disconnected"

I am connecting to server 2003 R2, Terminal Services, as an administrator, using RDP from Ubuntu 9.10 .
I am trying to remote control users connecting to the same server who are using Windows 7.
I can connect, but as soon as I try to do anything they get disconnected with a message that reads, "because of a protocol error, this session will be disconnected.  Please try connecting to the remote computer again".
I have tried every different RDP application for Ubuntu I can find, same error on each.  I have turned off every experience option on both the Win 7 and Ubuntu machines.  same error.

I have no issues if I log in to server 2003 using XP or windows 7 to remote control windows 7 users.  I also have no issues using remote control if I log in using Ubuntu and the users are anything other than Windows 7.  It is strictly if I am using Ubuntu and the other users are Windows 7.  Obviously something new with Windows 7.

Does anyone have any solutions for this?
LVL 2
FJS159Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TobiasHolmCommented:
Maybe you could install VNC server on the Win2003 server and use a VNC client on the Ubuntu machine to remote control the W2003srv through VNC?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FJS159Author Commented:
It looks like I will have to use VNC, even though I would prefer not to.
The issue appears to be that Windows 7 uses protocol version 7 for RDP.  Ubuntu uses 5.2
There is a protocol upgrade for XP and Vista, thus I have no issue when I use them, but I have found no similar upgrade for Ubuntu.

"All editions of Windows 7 include Remote Desktop Connection.
    *
      You can use Remote Desktop to initiate a connection from any edition of Windows 7.
    *
      You can connect to computers running Windows 7 Professional, Windows 7 Ultimate, or Windows 7 Enterprise.
    *
      You can't use Remote Desktop Connection to connect to computers running Windows 7 Starter, Windows 7 Home Basic, or Windows 7 Home Premium."

http://windows.microsoft.com/en-us/windows7/Remote-Desktop-Connection-frequently-asked-questions
0
FJS159Author Commented:
VNC Server doesn't solve the issue but it is an acceptable work around.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.