Cisco Anyconnect VPN Client vpnapi.dll failed to register

I am trying to install the vpn anyconnect client onto a laptop running XP SP3,
I get the following error during the installation:
Event Type:        Error
Event Source:    MsiInstaller
Event Category:                None
Event ID:              11904
Date:                     4/22/2010
Time:                     7:46:07 AM
User:                     domain\
Computer:          Laptop
Description:
Product: Cisco AnyConnect VPN Client -- Error 1904. Module C:\Program Files\Cisco\Cisco AnyConnect VPN Client\vpnapi.dll failed to register.  HRESULT -2147221164.  Contact your support personnel.

I have tried registering the dll without any errors, and can't seem to find much on this issue on the net.

I would greatly appreciate any assistance on this issue.

Thanks in advance.
talystAsked:
Who is Participating?
 
johnb6767Commented:
As an FYI, in case you havent seen this.....

How to Uninstall Manually and Upgrade the Cisco VPN Client 3.5 and Later for Windows 2000, Windows XP and Windows Vista
http://www.cisco.com/en/US/products/sw/secursw/ps2308/products_tech_note09186a0080094b7f.shtml
0
 
johnb6767Commented:
XP Pro/Home?
0
 
talystAuthor Commented:
XP pro
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
johnb6767Commented:
Ive had a few instances where the file wasnt actually present in the above path.... Guessing thats not the case?

Sorry, have to ask......
0
 
johnb6767Commented:
Was there a previous install of an earlier VPN client on this machine? Any services disabled that might be interfering?
0
 
johnb6767Commented:
And do you have the latest Windows Installer?
0
 
talystAuthor Commented:
There was an previous version installed, when the device connected to our vpn, it attempted to update and this is where it failed.  I have tried manually installing, cleaning any instance of cisco in the registry and program files directory with no success.  As for the windows installer, it has ver 3.1 installed.
0
 
johnb6767Commented:
I think you might have some remnants remaining......

Is there a log file that it creates? Cant remember if it does by default.....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.