Slow file copy - SonicWall NSA 2400 Firewall and VPN

I'm configuring a new server and firewall locally before I install it in the datacenter, and I'm having problems with file copy speed using VPN.  I know that I don't have to use VPN locally, but the point is that I'm trying to configure the server as if I were doing it remotely.  Here's the basic setup:

- Gigabit switch - desktop (that I'm trying to configure from) and SonicWall NSA 2400 are connected.  Thus, firewall and desktop are on the same subnet (192.168.0.10 and 192.168.0.200).
- Behind SonicWall is a Dell PowerConnect 2824 Switch in managed mode.  I've configured it with VLAN so that the DMZ and LAN networks can be segregated using the same switch, and thus only 1U of rack space.
- Behind the PowerConnect switch is my server.

All connections are gigabit.  When I VPN into my firewall (using SonicWall VPN Client), pings respond in < 1 ms.  However, when I copy files, the transfer rate is ~ 10 kb/s.  If I physically plug my desktop into LAN on the 2824 switch (thus bypassing the firewall and VPN), file transfers fly.  This obviously won't be the case when I'm remotely configuring the server.

Any ideas?  Thanks in advance.
LVL 1
msdcdevAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

msdcdevAuthor Commented:
Just a couple of other notes:

1.  When the desktop is connected directly to the 2824 switch, a 60 MB file is copied instantly.
2.  Through VPN, the same file takes over an hour.

Keep in mind that, even though the transfer is taking place over a VPN connection, all connections are local, gigabit connections (no internet involved).  Also, this is a Windows file copy operation, not FTP, HTTP, etc.
msdcdevAuthor Commented:
Well, I figured it out in case anyone else has the same issue.  Basically, I wasn't using the SonicWall VPN virtual network adapter for the connection.  You can check this by looking at your network adapters while connected to your VPN.  If it's disabled, it's not set up correctly.  Here are the steps to fix it (in SonicWall OS Enhanced 5.5.2.0-3o):

1.  Go to VPN > Settings.  Click the "Edit" icon on the VPN connection that you're using.  Click on Client, and set "Virtual Adapter Settings" to "DHCP Lease or Manual Configuration".
2.  Go to VPN > DHCP over VPN.  Select "Central Gateway" and click "Configure".  Check "Use Internal DHCP Server" and "For Global VPN Client".

When you reconnect, your SonicWall VPN adapter should be enabled, and it should be assigned an IP.  I was able to get about 10 MB/s on file transfer operations after this...which I assume is the best I can do over a VPN connection.

Not sure why this fixed the problem.  If anyone can shed some light on the reason, I'll award half of the points.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
digitapCommented:
To understand your description, you never had DHCP configured on the Sonicwall for GVC connections, right?  At least, that's how I'm reading it.  If you haven't configured your Sonicwall to provide GVCs with an IP, then it's not going to connect properly.  As you said, the GVC will show disabled.
Virus Depot: Cyber Crime Becomes Big Business

The rising threat of malware-as-a-service is not one to be overlooked. Malware-as-a-service is growing and easily purchased from a full-service cyber-criminal store in a “Virus Depot” fashion. View our webinar recording to learn how to best defend against these attacks!

msdcdevAuthor Commented:
Yeah, DHCP was not enabled for my VPN connections.  The connection worked, it was just very slow.
digitapCommented:
So, you have an internal DHCP server handing out IP to the GVC users?
msdcdevAuthor Commented:
No, DCHP was not enabled anywhere.  Everything is static (only servers are behind the firewall).
digitapCommented:
So, you have assigned your GVC a static IP?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.