Firefox Right click menu is covering up various cloud software rightclick menu

When I right click using some sort of cloud-based software program, the software programs right-click menu gets covered up by firefoxes rightclick menu. (See screenshot)

I've experienced this in both 5pm and Infusionsoft, so the problem is Firefox.

How do I fix this? Is there a way to mover where the right-click menu appears for firefox so it doesn't cover up important features of the online programs I use?
freshjuiceAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DmitriyCommented:
Could you try to uninstall Firefox, try doing right-click on your applications (verify that they are fine) and then reinstall Firefox?  Just a thought.
You could also switch to using Chrome/IE and see if the problem persists.
0
freshjuiceAuthor Commented:
Oops here is the  screenshot
4-22-2010-10-45-12-AM.png
0
freshjuiceAuthor Commented:
Firefox is my browser of choice. Switching is not an acceptable solution.

Testing on the other problems shows that the problem isn't there. Something about firefox makes the Right-menu persistent, even when sites disable it.

0
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

freshjuiceAuthor Commented:
Correcting my last statement:

Testing on the other *browsers* shows that the problem isn't there. Something about Firefox makes the Right-menu persistent, even when sites disable it.

Other options?
0
DmitriyCommented:
Can you try reinstalling Firefox?
0
freshjuiceAuthor Commented:
Reinstalling it did not solve the problem.
0
Marc ZCommented:
Are you running any Noscript add-ons?
Have you confirmed in FF Tools->Options->Content->Enable JavaScript is checked and you hit the Advanced button as well and confirm that "Disable or replace Context Menus" is checked?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
freshjuiceAuthor Commented:
"Disable or replace Context Menus" was unchecked.

Winner!
0
Marc ZCommented:
Thanks,
Glad to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.