WSS 3 Alternative Access Mappings Problem

I have created a Windows SharePoint Services 3 site with 3 applications (Sites).
At the moment I can access them by typing http://servername:7171, http://servername:8181 and http://servername:9191.

I want to be able to access them using FQDN such as http://wss.company-a.com, http://wss.company-b.com and http://wss.company-c.com.
In DNS i have set up "A" Records for each of the FQDn's pointing to there own IP addresses.
At the moment in IIS all the sites are set to (All Unassiigned).  If I set each site it's own IP address i can not access the site.

If I browse to http://wss.company-a:7171 then I can access the site.  I do not want to have to put port numbers on the end of my URl's though.

I believe that I have not got my Alternative Access Mappings correct but can not see what I have got wrong.

I have looked at various technet articles and bloggs to no avail.
Can someone please tell me what I need to put in the alternative access mappings in order for this to work.

At the moment if I click on edit Public Zone Urls for one of the sites I see the:

Default zone as http://servername:7171
Intranet zone is blank
Internet zone says http://wss.company-a.com
Custom zone is blank
Extranet zone says http://wss.company-a.com

As an added complication. Once I get this working as http:// access, I am going to need to get https:// working as this is going to be used externally from the company.  I know that for https to work I really do need each IIS site on it's own IP address.

At the moment Host headers are not being used anywhere.

If anyone needs further clarification please don't hesitate to ask.

Kevan



LVL 1
cmiadminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joefreedomCommented:
Kevan, please try the following:

In all honesty it has been awhile since i've played with AAM's but hopefully it will get you headed in the right direction.  There are a couple of really long but really informative documents on AAMs from Microsoft such as: http://technet.microsoft.com/en-us/library/cc288609.aspx

Also i've included a fix for an SSL redirect (I cannot take credit for creation of the script).

AAM's:
-Navigate to the Alternate Access Mappings site
-in the 'Alternate Access Mapping Collection:' select 'Change alternate access mapping'
-Select the site you wish to change
-Select 'Edit Public URLS'
-Enter in the URL you wish the end-user to utilize in the 'Default' field and select 'Save'
-My application has the same 'internal URL' as 'public URL for Zone' and the zone is 'Default'


SSL Redirect:
-Open IIS Manager, right-click your site and select 'Explore'
-Copy/Paste the following into a Notepad document and save it with an .HTM extension in the root directory of your site.:

<SCRIPT type=text/javascript>
<!--
if (location.protocol != 'https:')
{
window.location = 'https://'+ location.host + location.pathname + location.search;
//alert(location.host + location.pathname + location.search); Just for sanity check

}
// -->
</SCRIPT>

-Right-Click on your site and select 'Properties'
-Select 'Custom Errors'
-Select the '403;4' error and choose 'Edit...'
-Select Message Type 'File', browse to your newly created .htm document from the step above

-Restart the site (right-click site, 'stop', 'start'.  or cmd:  'iisreset -noforce')
-Test
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
larrbeCommented:
Hi
I think what you try to achieve does not work using AAM. AAM is designed to make SharePoint available under different URL's but not ports or protocols. You want to achieve some port redirection which can only be achieved be some sort of reverse proxy (apache) or hardware loadbalancers (like F5 BigIP's).
In order to get your scneario working I would try following approách:
1. Delete the three created web applications again
2. Assign your server three different physical IP addresses (this will make SSL handling easier as well). If SSL was not needed this is not a must, otherwise yes.
3. Create three new web applications and make sure you enter the hostheader field as shown in attached screenshot using wss.company-a.com / wss.company-b.com and wss.company-c.com as HostHeaders. Make sure to always specify Port 80!

This will create three individual websites, check them using IIS Management Console. All of them are now available using standard http over port 80.
If you want to use SSL you need three individual certificates for you URL's. In order to use those assign the certificates but make sure that you change the IP Assignment inside IIS Website settings from "All unassigned" to an individual IP address.

larrbre
webapp-creation.jpg
0
cmiadminAuthor Commented:
Hi

Thank you, your replies.  I have changed each site onto it's own IP address and can access the sites as http://company-a.com etc.

I had to change the default path from http://servername:port number to the address I wanted to use eg http://company-a.com.

I have added the https://sites to the Internet zone.

I am now testing but first signs are promising.

Regards

Kevan

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.