Static IP prevents outgoing connections - only DHCP works

I have an Exchange 2007 Sp1 installation running on Windows Server 2008x 64. I was having trouble after setting up an SMTP connector to the internet from this box, as I could not connect to any remote SMTP server. Also, Windows Update would not work.

I switch the network interface from being a static IP to using DHCP and all problems are resolved regarding my SMTP issues... but why would using DHCP allow SMTP traffic through when static IP does not?
LVL 1
alan2938Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
My guess is you have the subnet mask or default gateway setup incorrectly with the static config.
FayazCommented:
Take the DHCP configuration, from a command prompt IPCONFIG/ ALL and configure the same as static and check if that works and if so then change only the IP Address and keep all other as is.
Darius GhassemCommented:
Make sure your static IP address is on the same subnet as your DHCP address and it is pointing to the same DNS servers.
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

alan2938Author Commented:
All systems are on the same subnet and pointing to the correct servers.

I switched the Exchange server back to static IP using the exact settings that were given through DHCP... and upon reboot, the default gateway is blank. I add it in, the machine reboots again, and it doesn't make a difference. So for whatever reason, unless my server is configured for DHCP, it has no idea what my default gateway is.
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Default gateway is blank...I have seen this happen on multihomed servers?   If not multihomed I would take a look in the registry for any NICs that didn't get uninstalled properly....
 HKEY_LOCAL_MACHINE\System\CurrentControlSet\Network.

Some of the GUID keys are the NICS
Expand the guid keys and look for the subkey connection.  These are the NICS, check to see if there are any that have a IP that you don't reconize that should not be there.
alan2938Author Commented:
I don't have "Network" under CurrenControlSet. See image.
registry.png
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Sorry.... HKLM\System\CurrentControlSet\Control\Network\
alan2938Author Commented:
Ok, so I found there are lots of entries labelled for Local Area Connection 1 through 11. I attached a screens hot below of the descriptions... not sure if they correlate or not. I actually removed everything except Local Area Connection 2 (the only one connected right now... I'm in a Virtual Environment) but then LAN 2 completely disappeared! I had to restore from snapshot to get it back.
regedit.png
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Ah this looks correct, but for future testing you can export the registy key then remove it...if someone blows up you can just import the registy key that you exported.
MSFT_NET_SEECommented:
This is a somewhat common problem unfortunetly, up there is a fairly easy fix.
1. From a command prompt: ipconfig /all and note the name of each adapter listed. I.E. "network connection 2".
2. As mentioned, HKLM\SYSTEM\CCS\Control\Network\, looking for each ethernet network connection, noting the GUID of each that wasn't listed in step 1, then delete. Do NOT delete MINIPORTs, ISATAP, etc.
3. Under HKLM\SYSTEM\CCS\Services\ you'll find a list of GUIDS at the top under services. Delete the GUIDS that match those from step 2.
4. Under HKLM\SYSTEM\CCS\Services\tcpip\parameters\adapters, you'll have some GUIDs listed. Delete those that match GUIDS in step 2.
5. Under HKLM\SYSTEM\CCS\Services\tcpip\parameters\interfaces, you'll have a list of GUID's also. Delete those that match GUIDS in step 2.
6. Next, HKLM\SYSTEM\CCS\Services\tcpip\Linkage and open "Bind" and remove each GUID noted in step 2. Repeat this for Export and Route.
7. Finally, from the system console (or iLO card), open an elevated command prompt and type "netsh int ip reset c:\reset.log". Reboot to complete when prompt.
When the system comes back up after the restart, you'll need to reconfig the IP address information on the NIC, hence the need to be at the console, but the gateway should now survive a restart.
These steps should remove ghosted NICs from the registry completely.
alan2938Author Commented:
Did not work. I am going to just install a fresh copy of Server 08 with a new install of Exchange 07.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.