Word 2007 hangs wehn opening xml file

I am trying to open a xml file with Word 2007. It hangs on my computer everytime. I can open the same file on other computers just fine. We use this xml file as a mail merge template. It hangs both when opening it directly or through the mail merge function. My Word 2007 works fine for all other doc or docx files.

ANy ideas?

Ken
kgerthAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

redrumkevCommented:
kgerth,

How are you doing?

Try running detect and repair:

Office Button -> Word Options -> (left pane) Resources -> (right pane) run MS Off Diagnostics (Diagnose).

Is your system updated (run updates, same Resource page as Diagnose).

Try running Word in Safe Mode:
1. Click Start
 2. Click Run
 3. In the runbox type:  winword /safe
 4. Click OK or press Enter
 5. Word will open with (Safe Mode) in the title bar

While in Safe Mode, try opening the XML file.

When "opening it directly", do you mean double clicking the file, which launches Word? What if Word is already open and you go Office Button - Open -> Navigate to the file and Open it?

Let me know what happens,
Kevin
0
kgerthAuthor Commented:
Kevin,

I ran the diagnostics and found no errors/problem. I ran update and it found only updates for the help file though I installed them. I opened Word in safe mode and that allowed me to open the xml file. Closed safe mode and tried just opening Word and then couldn't open the xml file.

I am atempting to open from Office Button - Open -> Navigate to the file and Open .

Ken
0
redrumkevCommented:
Ken,

Once you have completed the Office Button -> Open -> Click on the file, let me know if it works or not.

Since the document opens via safe mode, then something loading with Word is causing the issue.

This explains the safe mode in (Office 2007):
http://office.microsoft.com/en-us/word/HP101407921033.aspx

I would say that one of your ad-ins is either corrupted or having some issue(s). See this link and try disabling all of our ad-ins:
http://office.microsoft.com/en-us/word/HA100341271033.aspx#2

Then you can try enabling one of them, close Word, then click on the file. If it opens correctly, that ad-in is fine. Once you go through these, one at a time, you will find the "bad one" and just "leave it off" and you should be good.

Hope this helps,
Kevin
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

kgerthAuthor Commented:
Kevin,

I only had 2 active add-ins. I have made them inactive. See attached. This had no effect on opening a xml file. Do I need to completely remove the inactive add-ins?

Ken
word-add-ins.doc
0
redrumkevCommented:
Ken,

With "Com Ad-in's" Showing, select Go and see what comes up. Should be your Crystal Reports, see if unchecking that works?

Eventually (once we determine which thing is causing this) you will want to try and reinstall that ad-in, thus getting its functionality back and still having Word work with XML files.

Do you use the crystal reports tags for anything? Or were they just installed by default from your company?
0
kgerthAuthor Commented:
I have nothing listed in the Com Ad-in's.

Ken
0
redrumkevCommented:
ken,

Lets try deleting your main document template (normal.dot) as Word will create another one. If this template is corrupt, then then new one should work fine, perhaps this is it.

Do this, follow these steps:
1.  Click on Start>Search>All Files & Folders and type normal.dot
     into the "Name or Partial Name:" field.  (Typing normal.dot
     will also find normal.dotm in Word 2007).

2.  Next click on Advanced Options and be sure that Search
     System Folders and Search Subfolders are checked, along
     with Search Hidden Files & Folders.

3.  Also, the "Look In:" field should be set to your main hard drive
     (usually Local Disk C:) rather than to an individual folder,
     such as "My Documents."

It's not uncommon to find multiple copies of normal.dot, so wait till the search has finished before deleting anything. When all the files have appeared they can be deleted by left-clicking them and pressing your DELETE key. Alternatively, you can select them and click the toolbar's red X. Or you can right-click them and choose DELETE on the popup menu.
Please note that normal.dot can not be deleted if any Word documents are open. Word must be closed in order to perform this action. After all copies of normal.dot have been purged you can reopen Word, which will go looking for the file. When it isn't found the program will simply recreate it with all of Word's original settings.

The above steps and info are from:
http://www.pcdon.com/word-unstable-corrupted-normal-dot.html

Kevin
0
redrumkevCommented:
Ken,

Also, the easiest fix, if you still run into the issue (after going through the normal.dot deletion process above), which on a side note, make sure Outlook is closed as well, actually make sure ALL OFFICE programs are closed when you do the delete, otherwise it might "still be open somewhere" and not remove it completely.

That would be to do the following.

Right click on your desktop and select New -> Shortcut

Copy and paste the following string:
"c:\program files\microsoft office\office12\winword.exe" /safe
Click next and call it Word 2007 Safe Mode

Now whenever you launch that icon, then open the document, you will be safe mode and all should be well. The rest of the time you launch Word, it will be in 'normal mode'.

If you want to know how to permanently put Word into Safe Mode, I can let me know that as well.

Kevin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kgerthAuthor Commented:
Kevin,

I deleted all the normal.dot* files. I still conanot open a xml file in Word. I will use your solution of safe mode for now.

Thanks for help.

Ken
0
kgerthAuthor Commented:
I am not sure if the points were awarded correctly. All 500 points should be awarded.

Ken
0
redrumkevCommented:
Ken,

Sounds good and you are right, we got it to a workable situation, not necessarily a solution, but it gets you moving forward!

I am going to object because right now, it is set to accept your solution of #31899219 and not award any points. A moderator will check this out and close the question.

Mods, per 31899419, the author is requesting all 500 points to redrumkev for the accepted solution in 31887864.

Regards,
Kevin
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.