SQL 2005, DB with collation in "spanish"

Hi!

I ´ve a server with windows server 2008 on english. It has SQL 2005 on spanish.

I need a DB with collation in "spanish" but I cannot select that.

How I can to resolve that?

Thnx
javiermorquechoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cyberkiwiCommented:
Hi there,

Have a look under Traditional_Spanish*
0
cyberkiwiCommented:
Or Modern_Spanish* in the collation dropdown
0
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
You have this many collations related to Spanish and choose any one of them in the dropdown while installing SQL Server or change it using ALTER DATABASE statement like

ALTER DATABASE ur_db_name COLLATE ur_collation_name
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

javiermorquechoAuthor Commented:
OK. Making the ALTER TABLE exist the posibility to get a DB with some type of demage?
0
javiermorquechoAuthor Commented:
My SQL error is:

Error-SQL.doc
0
Raja Jegan RSQL Server DBA & Architect, EE Solution GuideCommented:
Try setting / resetting collation of your master database and then try this.
And is there by any chance that you are at SP2 of your SQL Server 2005 and apply SP3 and check out..
0
cyberkiwiCommented:
Hi,

You have this error because the server default collation is not valid or SQL Server master catalog has become damaged.
In the

New Database wizard, go to Options page (choose from top left)
On the right side at the top, set Collation to modern_spanish or something - don't leave as "<server default>"

If that still doesn't work, run the query directly

CREATE DATABASE mydb COLLATE modern_spanish_ci_as

Let use know if you still have an issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.