Windows 2003 applications stop working

Hello,

Since a week I have a problem with my Server 2003 R2 Enterprise Edition with Exchange 2003 SP2 running in native mode. On this configuration I have JEP(S) greylisting 2.3.2.0 running, alon with GFI mail essentials 14.0. This worked fine for a long time.
A week ago, after a reboot of th server, JEP(S) didn't start and showed me the dialog box:

==========
An unhandled win32 exception ocurred in JEP(S) Greylist Admin.exe [7368]. Just-In-Yime debugging this exception failed with the following error: No installed debugger had Just-In-Time debugging enabled. In Visual Studio, Just-In-Time debugging can be enabled from Tools/Options/Debugging/Just-In-Time.
Check the documentation index for 'Just-in-time debugging, errors' for more information.
==========

I notice the JEP(S) service and the GFI service both are not running. I can start the JEP(S) service, but it stop short after the restart.
The GFI MailEssentials Managed Attendant service tells me it can't start.

When I look in the application eventlog I see a lot of 3 recurring logs:

==========
Event Type:      Error
Event Source:      .NET Runtime
Event Category:      None
Event ID:      1023
Date:            22-4-2010
Time:            12:45:33
User:            N/A
Computer:      MAIL
Description:
.NET Runtime version 2.0.50727.3607 - Fatal Execution Engine Error (7A09795E) (80131506)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
==========
Event Type:      Error
Event Source:      VsJITDebugger
Event Category:      None
Event ID:      4096
Date:            22-4-2010
Time:            12:45:33
User:            NT AUTHORITY\SYSTEM
Computer:      MAIL
Description:
An unhandled win32 exception occurred in mscorsvw.exe [5952]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

Check the documentation index for 'Just-in-time debugging, errors' for more information.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 02 00 5c 80               ..\¿    
==========
Event Type:      Error
Event Source:      .NET Runtime Optimization Service
Event Category:      None
Event ID:      1101
Date:            22-4-2010
Time:            12:45:33
User:            N/A
Computer:      MAIL
Description:
.NET Runtime Optimization Service (clr_optimization_v2.0.50727_32) - Failed to compile: System.Data.SqlXml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 . Error code = 0x800706be


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
==========

In the System log, I see a lot of recurring entries with the same error:
==========
Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7034
Date:            22-4-2010
Time:            3:46:34
User:            N/A
Computer:      MAIL
Description:
The File Server Storage Reports Manager service terminated unexpectedly.  It has done this 38 time(s).

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
==========

I removed an installed the File Server Storage Reports Manager again, without any succes. When I try to start File Server Management, a Visual Studio Just-In-Time Debugger dialog pops up, saying:
==========
An unhandled win32 exception ocurred in mmc.exe [6552]. Just-In-Yime debugging this exception failed with the following error: No installed debugger had Just-In-Time debugging enabled. In Visual Studio, Just-In-Time debugging can be enabled from Tools/Options/Debugging/Just-In-Time.
Check the documentation index for 'Just-in-time debugging, errors' for more information.
==========

It seems some "underlaying" element of Windows does not function. Can it be .Net framework? All versions are installed. I tried to reinstall .Net Framework 2.0 SP2, but that is not possible. Also http://support.microsoft.com/kb/908077 did not do the trick.

Some time ago I installed SQL Server 2005 express and deinstalled it after a short period. Could not see how this would be the problem. On the other hand, nothing else changed recently.

Hope anyone can help me.
RBraatAsked:
Who is Participating?
 
RBraatConnect With a Mentor Author Commented:
Yust for the knowledgebase:

A was pritty sure the problem was .Net 2. After a lot of documents found telling me how to repair and reinstall .net, without succes, I was able to remove .NET 2 with the tool ".Net cleanup tool". I removed .NET framework 2.0, rebooted and installed it again, without any problems, which was not possible before. Some services did not start. After a reboot all services restared and all applications that dit not work, worked agan. Until now no problems at all, Exchange is behaving normally as are GFI and JEP(S).
.NET cleanup tool is freely downloadable.
0
 
vb_studentCommented:
i do not know the fix but there is a recent post about a simmular problom here
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.