When opening My RDP,that was working, i get following error: The pre-release version of remote desktop connection has expried. to download the full version of remote desktop connection, go to windows

when i try to open my RDP -and it was woking--it now pops up a message that says the following verbatim. "The pre-release version of remote desktop connection has expried. to download the full version of remote desktop connection, go to windows update or contact your system administrator" I have tried some of the fixes suggested on previous  questions posted. one of them was the following, but could not find these files on a sp2 sys. I am running a sp3 xpp sys.and they said that sp3 put a trial ver. of this in place, so where do i get the files needed or the registry fix needed for this prob...here is what was suggested, and like i said i have a sp2 that i looked at and it did not have these suggested files to copy and put on my sp3 XPP.
vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
You can also copy/past following files from a Windows XP SP2 installation to the same directory on the windows XP SP3 machine.
It's possible that the SP2 files are also located on the SP3 machines in the uninstall dir: C:\WINDOWS\$NtUninstallKB925876$ - do a search to find them

C:\WINDOWS\system32\cmstscax.dll
C:\WINDOWS\system32\mstsc.exe
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Also have a problem with one machine that does not want to remote desktop. I have several mach. using remote desktop running xpp. they all work fine, but one does not. they are set up in sonicwall tz170, but i never set them up. I have tried to check everything to make sure that the one is the same as the ones that work with no luck. I am not familar with TS gateway and i am assuming that is  how it was setup. I am on a xpp machine that i am trying to connect to . We have a 2003 sbs as well as a windows 2003 r2 terminal server. The term.server may be involved i just am not sure. In the past it seemed as though the ip address was crutial to it working. I have the one in question setup just like the ones that work in the sonicwall. SO the prob. must either be on the desktop or the terminal server?
gstevederbyAsked:
Who is Participating?
 
Cris HannaCommented:
0
 
gstevederbyAuthor Commented:
you have to mix and match correct files when using pack 3 in xp
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.