Problem connecting to NAS using Linpus Lite Distribution

Hi there,

I'm currently using the Linux Linus Lite distribution on my Acer Aspire One netbook.

Unfortunately, I'm suffering a problem connecting to a network attached storage drive that is wired to my LAN. I have no problem connecting to this particular device through Windows terminals and the device itself works perfectly. The particular drive in question is a Freecom FSG-3.

However, as the file manager in Linpus Lite does not appear to support local networking as a native function, I have tried (unsuccessfully) various methods to overcome this issue.

In particular, I have created a folder in the root directory called 'NetFolder.' Following this I right-clicked on this folder and picked the 'Open Terminal Here' option. I then typed the command line:

I. First attempt I tried: sudo mount -t cifs -o username=[MY USERNAME],password=[MY PASSWORD] //10.0.0.3/fsg NetFolder

II. Second attempt I tried: sudo mount -t cifs -o username=[MY USERNAME],password=[MY PASSWORD] //10.0.0.3 NetFolder

III. Third attempt I tried: sudo mount -t cifs -o //10.0.0.3/fsg NetFolder

IV. Fourth attempt I tried: sudo mount -t cifs -o //10.0.0.3 NetFolder


NB. The username and password I have listed are the credentials I use to access this NAS through my Windows explorer (it allows me to view all the files on the drive and does not give access to specific FTP user accounts). In addition, the 'fsg' following the '10.0.0.3' is the network name for this device (the way it appears is you look for the device on a network management utility).


After trying them all of the above combinations, the Terminal application has displayed a number of error messages and I cannot see the contents of the NAS (which I should do if the attempt to add this drive is successful).

For example, the error message I received after trying statement I. above was "mount error: can not change directory into mount target NetFolder."

Has anybody got any idea of what might be the problem?


Cheers
spamsoftAsked:
Who is Participating?
 
rindiCommented:
So now it looks like a new error message. DFS looks like the distributed file system which m$ servers use, and domain looks like you are using Active Directory on the server. I've never used DFS, so I don't know much about that. I also haven't use Active Directory together with Linux, so also with that I don't have much knowledge.

Is the NAS your only "Server"? What type of OS is the NAS running on? How is the NAS setup, is there a web based utility for that? If you have a domain controller within your LAN, the shares of the NAS bight be managed by the DC, and that may make it impossible to make a connection with Linpus.

If there is no m$ server involved, what browsers are installed in Linpus? Some Linux browsers can be used to connect to samba shares, for example if you have Konqueror, and all the necessary plugins are installed, you can enter

smb://IPOfServer

(replace "IPOfServer" with IP Address of your NAS)

That should bring up the authentication display where you would enter your Username and Password, and after that you should be able to browse all the shared folders on the NAS to which that username has access to. Often that is all that is required and it isn't necessary to mount the share.

But it may be necessary to install additional software within Linpus, and I don't know whether that is available. If the netbook was mine, I'd probably make a backup image of the hard-disk so it is possible to return it to factory defaults, or replace the original HD with a new one, and install a more common version of Linux, like Ubuntu (I'd probably use Kubuntu as I prefer KDE over Gnome, and I think there is a netbook optimized version available). If you want to try that, the new version of Ubuntu 10.04 should become available next week or so, but you could also use the last RC version which was released today, from my experience with Ubuntu upgrading from the beta versions to the official versions is easy and straight-forward. Ubuntu (and other modern standard Linux distros) have support for m$'s Active Directory.

The problem with Linpus, and particularly those versions which are pre-installed, is that it isn't very standard and your usually at the mercy of the manufacturer as to what is installed and what isn't, and the netbook versions are usually very basic and hard to modify. These are usually also not meant for use in an office environment, but rather they are just meant for light internet browsing etc.
0
 
rindiCommented:
Your syntax is wrong. Try the below example (there should be a / in front of the mount-point).

sudo mount -t cifs -o username=[MY USERNAME],password=[MY PASSWORD] //10.0.0.3/fsg /NetFolder

If this still doesn't work, again note the error message you get and post it here.
0
 
spamsoftAuthor Commented:
Hi there,

Thanks for your help.

I have tried the following command lines with no success:

sudo mount -t cifs -o username=[MY USERNAME],password=[MY PASSWORD] a //10.0.0.3/fsg /NetFolder

sudo mount -t cifs -o username=[MY USERNAME],password=[MY PASSWORD] a //10.0.0.3/fsg

Note: NetFolder is the name of the folder on the Linpus Lite OS that I am mounting the NAS drive to (there isn't a folder on the NAS named 'NetFolder')


In both cases, I received the following error messages:

"Mounting the DFS root for domain not implemented yet
No ip address specified and hostname not found"
0
 
spamsoftAuthor Commented:
I was wondering what additional software could be installed on Linpus to rectify this problem?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.