Static routes on Dell Powerconnect 6024

I'm trying to configure a Dell Powerconnect 6024 with the IP routes below to replace a 3Com Corebuilder 3500 so that we can go full gigabit on our network. The problem that I'm having is every time I enter in a route I get the errors message "Only a directly connected router can be defined as the gateway".

The 6024 is currently running:
Software Version       2.0.0.01       
Boot Version       1.0.0.13       
Hardware Version       00.01.64

Not sure what I need to do to define these static routes. Any help is greatly appreciated.
Destination        Subnet Mask         Gateway       Status
Default Route                         192.168.1.50   Static
10.10.20.0      255.255.255.0         192.168.1.254  Static 
192.168.1.0     255.255.255.0                        Direct
192.168.7.0     255.255.255.0         192.168.1.254  Static
192.168.207.0   255.255.255.0         194.168.1.254  Static
216.6.208.192   255.255.255.224       192.168.1.52   Static

Open in new window

DalexanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Phil_taylor1980Commented:
it sounds to me like you are trying to add a route using a gateway that is not in a subnet/vlan directly connected to the switch.

is the code above the one you are trying to submit? it looks like you have everything on a /24 subnet (255.255.255.0) apart from the last route which is on a /27 subnet (255.255.255.224) so depending on your subnet ID the address 192.168.1.52 many not be an avaialbe address within the subnet?
0
Phil_taylor1980Commented:
sorry having just read that back i have mis read the table!
can you tell me your internal network and subnet because it would seem the 192.168.1.52 is not on the internal subnet.
0
DalexanAuthor Commented:
The 192.168.1.52 gateway is a connection to Concerto, for our ACD system, our internal network is 192.168.1.0 /24. It doesn't matter which route I try to enter they all give me the same error message.

Do I need to first static a port to each of the gateways in the table, then add the routes above?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

DalexanAuthor Commented:
Still can't define any static routes.

Do I need to define a directly connected router? If so how do I define it? Where do I define it? Why do I need to define a directly connected router when the 6024 will BE the router?

I tried defining port 1 to 192.168.1.254 and then setting a static route and I get an error that the gateway can't be a local IP address.

I tried setting port 1 to 192.168.1.0 and 192.168.0.0 and got illegal ip address.

I'm stuck like Chuck, any help is much appreciated.
0
Rick_O_ShayCommented:
You need to have at least one IP interface configured on the switch so in your case it would be on the 192.168.1.0/24 network. Something like:
(config)# interface vlan 1
(config-if)# ip address 192.168.1.254 255.255.255.0

When you put in the static route make sure you are setting the type as remote.
The next hop needs to be the interface IP address of another router connected to the same network but not your local switch's address.

Can you attach at least the router part of the config?
0
DalexanAuthor Commented:
A Dell tech recommended to go with creating VLANS for each of our internal networks and using the 6024 to handle talking across the different VLANS.

Currently everything is the 1.1 network and we want to break the different departments into their own networks

VLAN 5 for 192.168.5.0
VLAN 6 for 192.168.6.0
VLAN 7 for 192.168.7.0
VLAN 8 for 192.168.8.0

I've created the VLAN's and assigned them IP addresses.

Once this goes live how does DHCP handle new IP address requests? If it gets a request from a host on VALN 5 will it only give out address in the 5.0 network?
0
DalexanAuthor Commented:
I've got all the VLAN's configured and all the static routes entered in. Set up a testing system with the 6024, 2 2824's and 2 PC's on different VLAN's and I can ping between the two of them.

The only question I have now is how will DHCP handle new IP address requests? I know I have to turn on DHCP relay, my understanding is that the relay tells DCHP which subnet the request came from, I just want to make sure that hosts from each subnet only gets IP address for that subnet.
0
Rick_O_ShayCommented:
With the proper scopes configured you will just need to configure DHCP relay on each of the other interfaces to get the switch to relay the DHCP requests to the server's address.
0
DalexanAuthor Commented:
OK DHCP shouldn't be a problem then.

Now during testing I've ran into the problem that if a switch has hosts from different VLAN's on it then I can't talk across them even though the switch is connected to the 6024. I think this is because I have the ports on the 6024 configured to a specific VLAN.

I.E. port g5 on the 6024 is assigned to VLAN 5 if the switch thats connected to port g5 has hosts on it that are on other vlans then I can't ping between the two of them. From what I've found online it looks like I need to do trunking but I don't see a way to configure a trunk port on the switch. The switch is a Dell Powerconnect 2824.

I've tried going "config <> int eth g24 <> switchport mode trunk" (<> = enter) but I get unrecognized command. The manual for the 2824 says that page 106 shows how to configure trunking but on that page all it talks about is LAG configuration which I'm not familiar with.

We could go through the wiring in the server room and redo everything so that each switch only has hosts from a specific vlan but that would and monumental pain in the arse.  

Is there a way around having to do this?
0
DalexanAuthor Commented:
Further details on the last post:

If I move the switch to or change the port its connected to, to a trunk port on the 6024 I still can't ping across the vlans. Which I believe is because the port I'm connecting from the switch to the 6024 isn't configured as a trunk port.

If this is the case then I'm back to the situation that I described above.
0
Rick_O_ShayCommented:
You are seeing the expected behavior. Any time there are more than one VLANs on a specific link between switches that link needs to use VLAN tagging at both ends for each VLAN that is going to go over it. That is configured in the VLAN section. You basically add that port as a member of each VLAN and set it as tagged using the T vs the U for untagged.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DalexanAuthor Commented:
I must be missing a step somewhere. I've created:

Vlan 3  IP 192.168.3.1  
Vlan 4  IP 192.168.4.1  
Vlan 5  IP 192.168.5.1  
Vlan 6  IP 192.168.6.1  
Vlan 7  IP 192.168.7.1
Vlan 8  IP 192.168.8.1

I need to be able to have multiple vlans on any given switch, have that switch connected to the 6024 and then be able to talk across the vlan’s. With what I have set-up now I can only have 1 vlan on any given switch, once I start mixing vlans on the switch I can not longer ping between them.

On the 2824 switch for testing I've added vlans 3 and 6 and added them both as tagged to port g23 which connects to the 6024 at port g13 which is set to trunk and both vlans are set to tagged on the interface. The 2824 has a test PC on port 12 IP 129.168.3.6 and a test PC on port 2 IP 192.168.6.6.

I've attached the current running config from the 6024

run4-48.txt
0
DalexanAuthor Commented:
OK, I've got the above switch with multiple vlans connected to it to ping between the 2 test PC's. I had went into the ylan membership section and added them as tagged to the g23 port, but I never went into the port settings section and set the port that the test PC's where connecting to the vlan they where each part of.

So now at the switch I have:

port g2 set to vlan 3 for the 192.168.3.6 test PC
port g12 set to vlan 6 for the 192.168.6.6 test PC

If I understand this correctly then I will still have to know at the switch port level what vlan the PC on the other end is going to be a part of. Which, if correct, brings me back to the problem above there is no rhyme or reason to the current wiring layout in the server room.
0
Rick_O_ShayCommented:
I assume port 12 is in VLAN 3 and port 2 is in VLAN 6 on the 2824 and the PC's default gateway is the X.1 address for their respective VLAN/subnet. Also what is the IP forwarding table showing? Are all the local routes and static routes all in there as expected?

Also from your config file it looks like you have RIP and OSPF enabled. Do you have other routers out there that are using each of those protocols? You may be able to save a bunch of the switch's processing power if you turn off either or both of those if they aren't needed.
0
DalexanAuthor Commented:
Here's quick picture of our topology and where we want to go with it.
Topology.png
0
DalexanAuthor Commented:
AH switch the 3COm with the 6024 in the where we're going part.
0
DalexanAuthor Commented:
I made a mistake in my above posts

On the 2824:

PC 192.168.3.6 in on port g2
PC 192.168.6.6 is on port g12

Port g2 is now set to vlan 3
Port g12 is now set to vlan 6

Port g23 is set to vlan 3 and 6 tagged and connected to port g13 on the 6024

Port g13 is set to trunking mode


The forwarding table looks as expected, I've attached a screen shot of it so you can see it. I'm working on a diagram of what we would want the finished network to look like. Basically each vlan would have their own dedicated switches vlan8 would have 6+ switches as it has 140+ hosts on it. The only obstacle to doing that is having to trace out all the end terminations in the server room.



forwarding-table.PNG
0
DalexanAuthor Commented:
Here's where we would like to end up once the restructuring is completed.
Final-Layout.PNG
0
Rick_O_ShayCommented:
If you are going to separate the VLANs by switch, as shown in the picture, then you wouldn't need to have tagging on the uplinks. You would only need to use tagging if you have multiple VLANs on a single link.

The L3 6024 switch at the core would be the default gateway for each VLAN's IP network and should route everything VLAN to VLAN and anywhere else.

Can you test the VLAN to VLAN routing piece with those PCs directly coneccted to the 6024? Let's make sure we can do it locally before we start to add other switches and uplinks to the mix. You would just need to add a port in each VLAN. The route table looks good for all of your inter-VLAN routes and your statics out via the 192.168.1.0 network.
0
DalexanAuthor Commented:
I can ping across VLAN's either directly connected to the 6024, with dedicated switches per VLAN, or with mixed VLAN's per switch in place.

Since I have to know what VLAN the end host is to be a part of with mixed VLAN's in order to add the port to the right VLAN I have no choice but to back trace all the wires in the server room. They are labeled but no one knows how accurate the wiring diagram is and it only makes sense to go right to the layout with dedicated switches for each VLAN. It will definitely make things more time consuming but it'll only have to be done once and it'll make scaling the network in the future that much easier.
0
Rick_O_ShayCommented:
If you are doing the config from the CLI then I think you need to add all of the VLANs to the trunk port on one line like:

interface ethernet g13
switchport trunk allowed vlan add 3,5,6-8
exit
0
DalexanAuthor Commented:
Yes in order to trunk all the VLAN's across a single switch I need to do that, but to have multiple VLAN's on a switch I have to add the port the end host is connected to, to the right VLAN so that it's tagged properly. In order to add the ports to the right VLAN I'm stuck tracing the wires back to their end points to see whose the host at that end.

I.E. host 192.168.6.6 is on port 12, so port 12 had to be add to VLAN 6. In the test environment it's no problem knowing what end host is on what VLAN. Taking this set-up and going into production isn't this simple because the cables in the server room are a who knows where they terminate mismatch coming out of the wall. We've got a general idea from an old port chart what host is where and using that we're going to come in one night when no ones here and just disconnect 1 PC at a time and redraw the chart. Once we do that there isn't going to be a need for mixed VLAN's on a switch, we can just go ahead and configure the new network with dedicated switches for each VLAN.
0
Rick_O_ShayCommented:
About the only other thing you can do is use the arp table/cache to map IP address to MAC address and then go into the switch's forwarding database and see what port a specific MAC resides on.
0
DalexanAuthor Commented:
Rick,
Thank you for all the help, we've come up with a game plan and will be working on getting everything lined up and documented so when we go to install everything it should go right together without to many problems.
0
DalexanAuthor Commented:
Once I added the ports to the right VLAN everything worked, that was the part I was missing.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.