Chrome Type in SharePoint

I'm having a problem with setting the Chrome Type in MOSS 2007.  I'm not sure when it happened, because the last time I changed the Chrome Type was several months ago.  The strange thing is if I go to an existing list or document library and add another webpart to the page (for example, the same list, but with a different view), I can change the Chrome Type with no problems to something like "Title Only" or "Title and Border".  If I try to create a new document library or list, and attempt to change the Chrome Type, it will not stay once I exit the editing mode in the browser.  It let's me choose another option, but when exiting the edit page screen, it goes back to "none".  I've tried changing it in SharePoint Designer as well, and still no luck.  It's as if there is a global option overiding my changes for Chrome Type.  I've tried adding a new list at various places in the site to see if it is specific to one site, but it's not.  Thanks in advance.
SVMMikeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JoestetzCommented:
Unfortunately, I believe this is a behavior SharePoint enforces for the OOTB list/library views. Because those pages (I assume you mean http://mycorporateweb.com/PagesLibrary/Forms/AllItems.aspx as an example) are the landing paging for interacting with lists, they have a forced view. I am sure there is some way around this, but I have not had the need to use Chrome Type on these pages. In my opinion, it is best to have users not directly access lists, but instead have other mechanisms of adding and managing items elsewhere on the sites.
0
SVMMikeAuthor Commented:
The problem I'm having is that I can't get the Title for the webpart to show up at all in the Chrome.  I can Edit the Page, modify the webpart, scroll down to Chrome Type and change it from "None" to "Title" and hit ok.  It will appear as long as I am still in edit page mode, but as soon as I hit "Exit Edit Mode" the Title (for the Webpart) disappears again.  I go back to edit mode to check it's setting and the Chrome Type has been changed back to "None".  It just won't stay.
0
JoestetzCommented:
Like I said, SharePoint automatically does this for these pages. There is no OOTB way to get around this for that particular page. As a workaround, you can create a page in a document library (for instance, Pages) and place this List on that page as the sole web part. you would then be able to edit the Chrome Type on this page because it is not a defined list view page in SharePoint.

1. Create a document library called Pages (or something similar/use an existing one)
2. Create a Blank Web Part Page in the library
3. Add the list/libary as a Web Part from the Web Part picker.
4. Change the Chrome Type
5. In Site Settings, change the Quick Launch navigation to point to this page instead of the OOTB list
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SVMMikeAuthor Commented:
Excellent - thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.