Trouble setting up VPN server

Hi,

I'm currently renting a virtual server running Windows Server 2008 R2 which I'm trying to set it up as a VPN server but can't figure out how to do it. I tried doing it the simple way; adding an incoming connection in network connections. Unfortunately, the server only has one network adapter which has a remote IP address, so clients are unable to connect because there are no IP addresses available on the same subnet as the server. When manually setting the available range of IP addresses to an internal IP, I can connect to the server but then there is no internet access.

I then followed this guide http://www.windowsecurity.com/articles/Configuring-Windows-Server-2008-Remote-Access-SSL-VPN-Server-Part2.html, but when I got to figure 15 I couldn't follow any longer because the option for VPN and NAT requires 2 network adapters. I instead selected custom configuration and then VPN and NAT, but this leads to different configuration. I've never been one for managing networking so at this stage I was completely lost.

If anyone could point me in the right direction it would be very much appreciated.

Thanks
LVL 3
Corrup7ioNAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
If the machine has only public IP, you will have access to that single machine only (besides Internet access, of course).
To do that, your first approach was correct: Just set up a RRAS VPN, with an own IP address pool.
When connecting to the server via RAS (PPTP), take care that the "Use remote gateway" option is not ticked on. You should then only get a route to the IP address pool, leaving your default gateway alone - and you should have Internet access.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.