Port trunking between 3com 2924 and HP Procurve 2910al

Hi Experts,
I'm trying to setup port trunking between a 3com 2924-SFP and a HP Procurve 2910al switch and running into problems.  The trunk appears to be active (lights on the ports blinking) but there is no traffic flowing, can't see anything sitting behind either switch.  

By default the 3com had STP enabled so I enabled it on only the trunked hp ports - that didn't work.  I removed STP from both switches, that didn't work either... tried various combinations of things and nothing has worked.  LACP is disabled.  

I do have a couple VLAN's setup on the HP and ip routing is enabled.  Don't know if I have to have a matching VLAN on the 3com side (even though the entire 3com is in 1 subnet).  

Thanks in advance for the help!
sshinnickAsked:
Who is Participating?
 
from_expCommented:
hi!
lets us be more consistent here.
please leave rstp/mstp on (because you need someone to take care of redundant links, if LAG is not functioning as it supposed to)
mstp is fully backward compatible with rstp, so don't care about exact versions used.

no enable two ports (1-2) on hp (I don't like disable there). leave autoneg on. you don't need to care about autoneg between two switches unless both cann't successfully negotiate speeds/duplex settings.

interconnect two switches together with two links.

now let us look what is happening. you will need to check lag status, lacp status and spanning tree status for both ports. these statuses are important, so please post them here (switches are not like black boxes, they can provide you with a lot of useful troubleshooting info)
0
 
from_expCommented:
if you are mean link aggregation with word "trunking" then I don't understand why you have LACP disabled. 802.1ad (aka LACP) is the best way how to aggregate ports between two switches.
0
 
sshinnickAuthor Commented:
Yes, link aggregation.  In the HP docs, it said LACP was used for dynamic links.  I just didn't think that was something that I needed because I was trying to keep things simple.  I'm pretty green when it comes to switch configuration so I tend to leave things off rather than turn everything on unless I know I need it.  So definitely open to suggestions on the proper way to be doing this!  Do you think the LACP is the problem?

Thanks.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
from_expCommented:
LACP=Link Aggregation Control Protocol
so it cares about ports assigned to a trunk and communicates with the switch on the other end of trunk.
0
 
jburgaardCommented:
Please post your current config.
And also whitch ports on whitch switch are connected to whitch port on other switch.

Vlans and tagging must match.
Eventually an untagged vlan on HP can connect to a plain switch without vlans.
0
 
sshinnickAuthor Commented:
Things are a bit mismatched right now because I have been trying to get things working.

VLAN on HP is untagged.  

Port 1 & Port 2 on both switches are the ones I'm trying to trunk.

3com config:
interface port-channel 1
description Lag1
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
interface range ethernet (1-2)
channel-group 1 mode on
exit
interface vlan 1
ip address 192.168.1.198 255.255.255.0
exit
ip default-gateway 192.168.1.235
hostname hou-3com2924-05
username admin password *** level 15 encrypted
snmp-server location "Rack3"
snmp-server contact IS
snmp-server community private rw view DefaultSuper
snmp-server community public ro view Default
clock summer-time recurring usa

HP config:
Startup configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "hp2910_2"
module 1 type J9147A
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 43-44
   ip address 192.168.199.1 255.255.255.0
   no untagged 1-42,45-48
   exit
vlan 10
   name "HOU-1"
   untagged 1-32,45-48
   ip address 192.168.1.3 255.255.255.0
   exit
vlan 20
   name "HOU-10"
   untagged 33-36
   ip address 192.168.10.3 255.255.255.0
   exit
vlan 30
   name "HOU-13"
   untagged 37-40
   ip address 192.168.13.3 255.255.255.0
   exit
vlan 40
   name "HOU-TEST"
   untagged 41-42
   ip address 192.168.100.3 255.255.255.0
   exit
no dhcp-relay
ip route 0.0.0.0 0.0.0.0 192.168.1.235
snmp-server community "public" unrestricted
password manager
password operator

Thx...
0
 
sshinnickAuthor Commented:
Also... not sure where that "voice vlan oui-table..." entries on the 3com came from.  Built in maybe?  Don't know if they matter...
0
 
sshinnickAuthor Commented:
If it helps, let me explain what I am trying to do.  I want to make the HP switch my consolidation point for all my other network equipment.  I do have another floor on a subnet and it currently sits behind its own cisco router which I'd like to free up if I can get vlan and trunking working on this switch - that is the .13 subnet.  That's a whole other discussion...

The .1 subnet is where all my users and servers sit.  I have about a dozen switches (hp and 3coms) in the server room that I'd like to converge onto this switch.  

The 3coms (6 of them) sit at the top of each server rack so I'd like to turn on the port trunking (link aggregation) so they have larger pipe back to the main HP switch.  
Thx...
0
 
sshinnickAuthor Commented:
I have tried turning on LACP on both switches, no luck.  Not sure what I'm missing...
0
 
from_expCommented:
hi!
I don't see any configuration settings for LAG in HP config.
can you post running config of HP, please.
0
 
sshinnickAuthor Commented:
Yes sorry, I've been playing with the config so the previous post didn't show any LAG's.  Here's my latest attempt with lacp enabled on both switches and an untagged vlan enabled on the 3com.  HP uses MSTP for spanning tree and I noticed the 3com used RSTP so I tried making the HP use RSTP.  Additionally, I tried turning off STP on both devices.  None of that worked.  

HP config:
Startup configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "hp2910_2"
module 1 type J9147A
interface 1
   disable
   speed-duplex auto-1000
   lacp Active
exit
interface 2
   disable
   speed-duplex auto-1000
   lacp Active
exit
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-2,43-44
   ip address 192.168.199.1 255.255.255.0
   no untagged 3-42,45-48
   exit
vlan 10
   name "HOU-1"
   untagged 3-32,45-48
   ip address 192.168.1.3 255.255.255.0
   exit
vlan 20
   name "HOU-10"
   untagged 33-36
   ip address 192.168.10.3 255.255.255.0
   exit
vlan 30
   name "HOU-13"
   untagged 37-40
   ip address 192.168.13.3 255.255.255.0
   exit
vlan 40
   name "HOU-TEST"
   untagged 41-42
   ip address 192.168.100.3 255.255.255.0
   exit
no dhcp-relay
ip route 0.0.0.0 0.0.0.0 192.168.1.235
snmp-server community "public" unrestricted
spanning-tree
spanning-tree force-version rstp-operation
password manager
password operator

Looks like I've cut myself off from the 3com switch so I can't post that config currently... will post it tomorrow am.
This is so puzzling because it seems like it should work.   Thanks...  

0
 
sshinnickAuthor Commented:
Also note, I read in the HP doc's that port trunks needed to be set to auto neg but 3com says LAG's need to be set to non-auto full duplex so I tried hard setting both sides as another test - with no luck.
0
 
sshinnickAuthor Commented:
Yes, I understand, it is hard to troubleshoot if I keep changing things.  I have just been desperate to try to get things working so trying different settings... So I'll quit doing that :)

I'll make the changes you mentioned and post the configs here.

Thanks for the help.

0
 
sshinnickAuthor Commented:
Ports 1 & 2 on both the 3com and HP are connected to one another, I do have link lights but the switches can not ping each other.  Nor can workstations behind either switch see anything beyond the switch they are attached to.  

The 3com shows STP is enabled but I noticed when I download the config, it doesn't show it.
STP settings are STP - enable, port fast - disable, root guard - disable, port state - discarding, speed - 1000m,
path cost - 4, priority - 128, rstp link type - auto

====================
Here is the 3com config:
====================

interface port-channel 1
description Lag1
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
interface range ethernet (1-2)
channel-group 1 mode on
exit
interface vlan 1
ip address 192.168.1.198 255.255.255.0
exit
ip default-gateway 192.168.1.235
hostname hou-3com2924-05
username admin password
snmp-server location "Rack3"
snmp-server contact IS
snmp-server community private rw view DefaultSuper
snmp-server community public ro view Default
clock summer-time recurring usa

====================
Here is the HP config:
=====================
Startup configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "hou_hp2910_2"
module 1 type J9147A
interface 1
   lacp Active
exit
interface 2
   lacp Active
exit
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-2,43-44
   ip address 192.168.199.1 255.255.255.0
   no untagged 3-42,45-48
   exit
vlan 10
   name "HOU-1"
   untagged 3-32,45-48
   ip address 192.168.1.3 255.255.255.0
   exit
vlan 20
   name "HOU-10"
   untagged 33-36
   ip address 192.168.10.3 255.255.255.0
   exit
vlan 30
   name "HOU-13"
   untagged 37-40
   ip address 192.168.13.3 255.255.255.0
   exit
vlan 40
   name "HOU-TEST"
   untagged 41-42
   ip address 192.168.100.3 255.255.255.0
   exit
no dhcp-relay
ip route 0.0.0.0 0.0.0.0 192.168.1.235
snmp-server community "public" unrestricted
password manager
password operator


0
 
sshinnickAuthor Commented:
Spanning tree is on the HP (turned it on after I posted the above) - set it back to MSTP as you specified it was backwards compatible.

================
HP Spanning Tree
================
Multiple Spanning Tree (MST) Information

  STP Enabled   : Yes
  Force Version : MSTP-operation
  IST Mapped VLANs : 1-4094
  Switch Priority    : 32768
  Max Age  : 20
  Max Hops : 20
  Forward Delay : 15

  Topology Change Count  : 4
  Time Since Last Change : 8 secs

  CST Root Priority    : 32768
  CST Root Path Cost   : 20004
  CST Root Port        : 11

  IST Regional Root Priority    : 32768
  IST Regional Root Path Cost   : 0
0
 
sshinnickAuthor Commented:
Bottom of the HP config just added this line.... spanning-tree

================
HP Config
================

no dhcp-relay
ip route 0.0.0.0 0.0.0.0 192.168.1.235
snmp-server community "public" unrestricted
spanning-tree
password manager
password operator
0
 
jburgaardCommented:
Do you not need a groupID on HP?
 like 'trk1' in:
trunk 1-2 trk1 lacp
0
 
sshinnickAuthor Commented:
Yes, you are correct - I did miss that.  Thx... In the HP documentation, it says:  
VLANS and Dynamic LACP - A dynamic LACP trunk operates only in the default VLAN (unless you have enabled GVRP on the switch and use Forbid to prevent the ports from joining the default VLAN).

If you want to use LACP for a trunk on a non-default VLAN and GVRP is disabled, configure the trunk as a static trunk.  

So, what do you recommend?  I'm not using the default VLAN for the 3com switch.
0
 
sshinnickAuthor Commented:
I'm not sure how to disable the GVRP or use Forbid and I don't see it in the doc... but I'll continue to look if you think LACP is a better way to go instead of static.
0
 
sshinnickAuthor Commented:
WOW, that seemed to be this missing piece.   I disabled GVRP and had to FORBID the trunk on other VLANS other than the one the 3com was connected to to get this working.  I still wouldn't mind some feedback on if this is a good way of doing things?   Thanks so much for everyone's help.

Here's my latest HP config - I didn't change anything on the 3com...

=====================

Startup configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "hou_hp2910_2"
module 1 type J9147A
trunk 1-2 Trk1 LACP
ip routing
vlan 1
   name "DEFAULT_VLAN"
   forbid Trk1
   untagged 43-44
   ip address 192.168.199.1 255.255.255.0
   no untagged 3-42,45-48,Trk1
   exit
vlan 10
   name "HOU-1"
   untagged 3-32,45-48,Trk1
   ip address 192.168.1.3 255.255.255.0
   exit
vlan 20
   name "HOU-10"
   forbid Trk1
   untagged 33-36
   ip address 192.168.10.3 255.255.255.0
   exit
vlan 30
   name "HOU-13"
   forbid Trk1
   untagged 37-40
   ip address 192.168.13.3 255.255.255.0
   exit
vlan 40
   name "HOU-TEST"
   forbid Trk1
   untagged 41-42
   ip address 192.168.100.3 255.255.255.0
   exit
no dhcp-relay
ip route 0.0.0.0 0.0.0.0 192.168.1.235
snmp-server community "public" unrestricted
spanning-tree
spanning-tree Trk1 priority 4
password manager
password operator
0
 
sshinnickAuthor Commented:
I've split the points since you both helped me get to the final solution.  Thx.
0
 
from_expCommented:
congrats!
you did it!
please also check active lacp stats on both switches - just to be sure, that both ports are functioning
0
 
sshinnickAuthor Commented:
Yes, everything seems to be working fine.  Thanks again for the help.  Been working on this for a week and it was driving me crazy.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.