How do I setup Cisco ASA 5505 VPN from default

I just got a Cisco ASA 5505 and I want to set it up so I can VPN into my internal network from the WAN

: Saved
:
ASA Version 8.0(2)
!
hostname ciscoasa
enable password 062nJp4mAjy6XE/f encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
 webvpn
  file-browsing enable
  file-entry enable
  http-proxy disable
  url-entry enable
http server enable
http 192.168.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.0.2-192.168.1.1 inside
!

threat-detection basic-threat
threat-detection statistics
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
webvpn
prompt hostname context
Cryptochecksum:81064bfc9043e558b214b24fb9b3345a
: end
asdm image disk0:/asdm-602.bin
no asdm history enable
mrhankie91Asked:
Who is Participating?
 
Pete LongTechnical ConsultantCommented:
>>Will that method allow me to connect to my network remotely with AnyConnect?

no I wrote a different one for AnyConnect

http://petenetlive.com/KB/Article/0000069.htm
0
 
Istvan KalmarHead of IT Security Division Commented:
Hi,,

Here is that you need:

http://www.petenetlive.com/KB/Article/0000072.htm

Best regards,
Istvan
0
 
Pete LongTechnical ConsultantCommented:
Horay!
0
Turn Raw Data into a Real Career

There’s a growing demand for qualified analysts who can make sense of Big Data. With an MS in Data Analytics, you can become the data mining, management, mapping, and munging expert that today’s leading corporations desperately need.

 
mrhankie91Author Commented:
Will that method allow me to connect to my network remotely with AnyConnect?
0
 
mrhankie91Author Commented:
AnyConnect, Cisco VPN Adapter or even the microsoft vpn connection; either of these methods will work if I can figure out how to set it up on the firewall to connect to. For the Site to Site connection to work, there has to be another cisco firewall at the other end. I'm wanting to travel somewhere and be able to connect to my internal network via the internet.
0
 
mrhankie91Author Commented:
I ran the setup and I can login via web browser but when I try to download anyconnect it fails. I already have it installed so I can see if the VPN part is working and I cannot login to it either. When I try to access my network through the web VPN it says failed to retrieve domains.
0
 
mrhankie91Author Commented:
Never mind, freaking Firefox wouldn't let it work. IE8 allowed me to download it and connect to my VPN, however it doesn't do anything, no internet and no communication to my remote network. All I got was an IP from the ASA device.
0
 
mrhankie91Author Commented:
I can VPN into the ASA device but I do not have any access to anything.
0
 
Pete LongTechnical ConsultantCommented:
Did you add the NAT Exemption rule?
0
 
mrhankie91Author Commented:
Yes, unfortunately I misread and got the IP's backwards. Now there is communication with my network but still no internet connectivity.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.