How do I get Autodiscover service working for a user logged in locally to a laptop?

Hi, Can you please help?

Just recently installed Exchange 2007 SP1 and I have run into a problem. Our school has staff laptops which users log on locally and because of this, the OAB and the Autodiscover is having problems. Outlook clients keep on crashing and when Outlook initially sends/receives it takes a very long time, gets stuck on 5 seconds and shows an error:-

Reported error (0x8004010f): the operation failed,an object cannot be found.

If I uncheck download OAB in send/receive options then the issue is a temporarily fixed as Outlook doesn't crash but I still get the error above. Disabling downloading OAB is not an option as I would like this feature to work for staff.

I was given a possible solution, which was to create an internal SRV record. I did this and it hasn't resolved the issue.

Do you think creating an external SRV record will resolve the issue?

RMGSAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BusbarSolutions ArchitectCommented:
Nop, Local user's should work fine with the Exchange and autodiscover, it looks that something is wrong with the windows or outlook configuration, keep in mind that autodiscover is a subject and OAB is another one.
for OAB: I believe that the problem that users cannot query the AD so they try to connect to the OAB external URL, do you have configured on the OAB virtual directory (The External URL), it can be the same as the internal one, or can use an External FQDN.
0
RMGSAuthor Commented:
Hi Busbar,

Yes I have configured the OAB virtual directory and the internal and external urls.

Internally I can access https://excsvr.ad.rmgs/oab/efc3a76b-9a5c-4d11-b1ae-f754fa887e33/oab.xml
0
BusbarSolutions ArchitectCommented:
what is the external URL, and can the user how is not joined to the domain access it
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

RMGSAuthor Commented:
This is where I am getting confused. When I right click the Outlook icon in the system tray, then Test Email Autoconfiguration, test Autodiscover.

Autodiscover to https://rmgs.org.uk/autodiscover/autodiscover.xml
Autodiscover internet timeout against url https://rmgs.org.uk/autodiscover/autodiscover.xml
......

The above urls are wrong, as those to point to anything. They should be pointing to https://mail.rmgs.org.uk/autodiscover/autodiscover.xml
0
BusbarSolutions ArchitectCommented:
can you go to powershell and type
Set-ClientAccessServer –Identity <CAS Server Name> -AutoDiscoverServiceInternalUri: <Internal URL> -AutoDiscoverServiceExternalUri: <External URL>

and restart IIS and try again
0
RMGSAuthor Commented:
Set-ClientAccessServer : A parameter cannot be found that matches parameter nam
e 'AutoDiscoverServiceInternalUrl'.
At line:1 char:80
+ Set-ClientAccessServer -Identity Dione.ad.rmgs -AutoDiscoverServiceInternalUr
l:h <<<< ttps://dione.ad.rmgs/autodiscover -AutoDiscoverServiceExternalUrl: htt
ps://mail.rmgs.org.uk/autodiscover

Sorry to be a pain but thats the error I get
0
BusbarSolutions ArchitectCommented:
sorry use this cmdlet
Set-WebServicesVirtualDirectory -identity "CAS01\EWS (Default Web Site)" -externalurl https://mail.contoso.com/EWS/Exchange.asmx
0
BusbarSolutions ArchitectCommented:
were the CAS01 is you cas serer name
0
RMGSAuthor Commented:
Busbar, I have done that and restarted IIS. Just out of interest, what does that command do to help this problem?
0
BusbarSolutions ArchitectCommented:
this corrects the autodiscover settings on the Exchange, now users will connect to the URL you typed
0
RMGSAuthor Commented:
Hi Busbar, please accept my apology for the late reply but I was away for the weekend. Back to this problem; I cannot figure out why I am having these issues.When you type https://mail.rmgs.org.uk/autodiscover/autodiscover.xml into the browser it displays:-

  <?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="10:32:36.5916628" Id="2919603893">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>

Does this mean I need to remove teh autodiscover virtual directory and recreate?
0
BusbarSolutions ArchitectCommented:
Yes please
also try autodiscover.rmgs.org.uk
0
RMGSAuthor Commented:
Hi Busbar, firstly thank you for your help. Finally its all resolved.

The solution to this problem was:-

1. Remove the autodiscover virtual directory
Remove-AutodiscoverVirtualDirectory –Identity "cas-servername\Autodiscover (Default Web Site)"

2. Recreate the autodiscovery virtual directory
New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -WindowsAuthentication $true -BasicAuthentication $true

3. Check Authentication in ISS for the directory is the same as before

4. Restart IIS

5. Set the Autodiscover Internal URL.
set-clientAccessServer -Identity "CAS_server" -AutodiscoverServiceInternalUri "Https://CAS_server.domain/autodiscover/autodiscover.xml"

This is what worked for me so I hope it helps whoever has a similiar problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BusbarSolutions ArchitectCommented:
glad that I helped
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.