Using Linksys Router as an Access Point

Hi guys, I have a WRT160N wireless router than I'm essentially trying to use as a glorified access point, but I can't figure out how to configure it.

I can get a wired machine connected to the internet without the linksys at all by assigning a static IP to the machine (192.168.1.1), pointing the machine to the WAN port on the router for the gateway (192.168.1.254), and using my ISP DNS servers without any problem. Internet works fine.

What I want to do, is get the linksys in behind the router to provide wireless access, but can't figure out how to configure it. If I plug the internet port on the linksys into the WAN port on the real router, I'd need to statically set the IP since the WAN port on the router does not provide DHCP. I know what the gateway is (192.168.1.254), but don't really know what to put as the internet IP, or if I'm going down the wrong path completley.

Can anyone lend a hand?
LVL 4
jschwegAsked:
Who is Participating?
 
hawardenCommented:
I have a WRT310N set up in this configuration behind a dlink EBR3210. I have the WRT310N configured with a static internal ip address, in my case 192.168.0.2, and i have routing turned off. I have nothing plugged into the WAN port on the WRT310N and a network cable connecting one of the internal network ports to one of the internal network ports on the EBR2310. The EBR2310 is configured with 192.168.0.1 on the internal network and my ISP's assigned ip on it's WAN interface, which is connected to my DSL modem.

By disabling the routing on the WRT310N and using only the internal ports on it, I have effectively turned it into a wireless switch. And it works just fine, I'm sitting in my living room on my wireless laptop typing this right now.

I hope this helps!
0
 
jschwegAuthor Commented:
That sounds like what I want to do, but how do I turn routing off, I can't find that anywhere. That might be the peice of the puzzle I'm missing.

I tried to just plug both the internet router and my machine into the LAN ports only, but when DHCP hands out the address, the linksys has no idea how to route anything to the correct gateway (as it thinks that IT is the gateway still).
0
 
hawardenCommented:
I'm at work now so I don't have the interface in front of me at the moment, but there was a screen that had radio buttons for enabling/disabling NAT and RIP. Both of those need to be disabled.

http://www6.nohold.net/Cisco2/login.aspx?vw=1&pid=96&docid=c1b74e13866d4f32aa219293024e20bc_5563.xml&app=search&login=1
On this page, do you see the menus under Setup? Click on Advanced Routing. I believe that is where I saw the options to disable NAT and RIP. You should also make sure that you are only running the DHCP server on the device you want to run it on. Multiple devices running it can cause problems in other areas.
0
 
jschwegAuthor Commented:
Yeah, I found it. The other part was not using DHCP on the linksys, and rather enabling it on the main router. Thanks for the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.