One Server, Two NICs, Two Networks, IP Address used on wrong NIC

I have a server running Windows Server 2003 Standard with SP2.  This server has two network cards.  One is used for standard network traffic and the other is used for iSCSI.  The problem is that standard network traffic is being sent on the correct network card but with the wrong IP address.

The iSCSI NIC has an IP address of 172.24.8.4.  NIC #2 has an IP address of 192.168.11.52.  My firewall is getting packets from NIC #2 with the source IP address of 172.24.8.4.

Why is traffic coming from NIC #2 with the wrong IP address?  How do I fix this server so that this does not happen?

I have included the "ipconfig /all" and "route print" output.
C:\>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : myserver
   Primary Dns Suffix  . . . . . . . : mydomain.com
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : mydomain.com

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : HP NC373i Multifunction Gigabit Server Adapter
   Physical Address. . . . . . . . . : 00-19-BB-33-FB-7E
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 172.24.8.4
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : HP NC373i Multifunction Gigabit Server Adapter #2
   Physical Address. . . . . . . . . : 00-19-BB-33-FB-82
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.11.52
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : 192.168.11.5
   DNS Servers . . . . . . . . . . . : 192.168.11.3
                                       192.168.11.20

C:\>route print

IPv4 Route Table
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 19 bb 33 fb 7e ...... HP NC373i Multifunction Gigabit Server Adapter
0x10004 ...00 19 bb 33 fb 82 ...... HP NC373i Multifunction Gigabit Server Adapter #2
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     192.168.11.5    192.168.11.52     10
        127.0.0.0        255.0.0.0        127.0.0.1        127.0.0.1      1
       172.24.8.0    255.255.255.0       172.24.8.4       172.24.8.4     10
       172.24.8.4  255.255.255.255        127.0.0.1        127.0.0.1     10
   172.24.255.255  255.255.255.255       172.24.8.4       172.24.8.4     10
     192.168.10.0    255.255.254.0    192.168.11.52    192.168.11.52     10
    192.168.11.52  255.255.255.255        127.0.0.1        127.0.0.1     10
   192.168.11.255  255.255.255.255    192.168.11.52    192.168.11.52     10
        224.0.0.0        240.0.0.0       172.24.8.4       172.24.8.4     10
        224.0.0.0        240.0.0.0    192.168.11.52    192.168.11.52     10
  255.255.255.255  255.255.255.255       172.24.8.4       172.24.8.4      1
  255.255.255.255  255.255.255.255    192.168.11.52    192.168.11.52      1
Default Gateway:      192.168.11.5
===========================================================================
Persistent Routes:
  None

Open in new window

LVL 4
NGPSoft1Asked:
Who is Participating?
 
mcsweenSr. Network AdministratorCommented:
Also uncheck all the boxes under the iSCSI NIC in the advanced settings noted above.

Also your firewall should never be able to see the iSCSI nic.  Best practices state that an iSCSI network should be completely segregated from regular production networks.  You can do this by using a VLAN or using a separate switch not connected to the production LAN.

My guess is the packets you see at your firewall are broadcast packets.  Have you taken a packet sniffer to look at the headers?
0
 
Hypercat (Deb)Commented:
Check the binding order (Network Properties/Advanced/Advanced Settings) and make sure that the NIC with the 192.168.11.52 address is first in the binding order.
0
 
NGPSoft1Author Commented:
mcsween, the iSCSI network is a segregated network.  The NIC using iSCSI is not connected in any way to the network with the firewall.

I will check out the advanced settings that you and hypercat recommended.
0
 
NGPSoft1Author Commented:
Changing the binding order did not stop the traffic.  Removing the bindings from the NIC for iSCSI did stop the traffic.  Thanks to both hypercat and mcsween for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.