Moving Master db - I screwed up - HELP! SQL Server 2000

I tried to move the master.mdf using the instructions from below and now I can't connect to the server.  I get Unable to connect to server AB4000 - SQL Server does not exist or access denied.

I tried moving master.mdf & mastlog.ldf back to the original folder and still have the same problem.  I'm sure I screwed up some place, but my question is where do I go from here?

Thanks in advance for any help.
LJG


--- below from website http://www.myitforum.com/articles/18/view.asp?id=4077 -----
      
Moving SQL 2000 System Databases

By: Dana Daugherty
Posted On: 9/23/2002

This article gives step by step instructions for moving each Microsoft SQL Server 2000
system database to a different location on the same server.

When moving system databases there are different steps required depending on which of the four system databases being moved. System databases are automatically created upon installation of MS SQL Server 2000 and include:

Master
Model
MSDB
TempDB

NOTE: Stop all SMS services prior to moving any databases.


Moving the Master Database
The location of the master database and its associated log can be changed from within SQL Server Enterprise Manager. To do this:

Open SQL Enterprise Manger and drill down to the proper database server.

Right-click the SQL Server in Enterprise Manager and click Properties.

Click the Startup Parameters button and you will see something similar to the following entries:
-dD:\MSSQL\data\master.mdf
-eD:\MSSQL\log\ErrorLog
-lD:\MSSQL\data\mastlog.ldf
-d is the fully qualified path for the master database data file.
-e is the fully qualified path for the error log file.
-l is the fully qualified path for the master database log file.

Change these values as follows:
Remove the current entries for the Master.mdf and Mastlog.ldf files.
Add new entries specifying the new location:
-dE:\SQLDATA\master.mdf
-lE:\SQLDATA\mastlog.ldf

Stop SQL Server.

Copy the Master.mdf and Mastlog.ldf files to the new location (E:\Sqldata).

Restart SQL Server.
LVL 2
LJGAsked:
Who is Participating?
 
mikkilineniConnect With a Mentor Commented:
Can you please look imn the Event viewer and post the errors
0
 
LJGAuthor Commented:
Problem Solved:
In the log I had an error message "Invalid command option I."

When I saw "-l is the fully qualified path for the master database log file." I saw the '-l' as an 'I' instead of an L.

To solve the problem I corrected the following in the Registry.

HKEY_LOCAL_MACHINE\Software\Microsoft\MSSQLServer\MSSQLServer\Parameters\SQLARG1
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.