Getting a Quantum Superloader 3 to show up in Backup Exec 12.5 as a library

Hello

I purchased a quantum superloader 3 with 16 slots and the DLT-V4 Drive.  It came with Backupexec 12.5 express included.  I have installed the drive, connected it through the HP SC11Xe HBA P/N 412911-B21.

In backup exec, the device shows up as a single drive.  The robotic library is empty.  

I have tried changing the SCSI ID, Made sure the library is set to Random, I am using the drivers built into BackupExec as suggested.

I am a arcserve guy typically so Backupexec is new to me.  In Arcserve I would just run a device config wizard which would tie the slots to the drive.  When I run the device configuration wizard in BE, it just tells me that it is a single drive.  nothing to configure.

Any suggestions?
LVL 5
TheMetalicOneAsked:
Who is Participating?
 
TheMetalicOneAuthor Commented:
Thank you, I have tried to get the drivers changed, adjusted SCSI ID's, etc.  Still no effect.  

I found this on Quantum's site:

***************************************
Symptom:

SuperLoader3 VS160 Changer is not shown in Windows 2008 Device Manager when SuperLoader3 is connected with SCSI Ultra320 HBA. It only shows the VS160 tape drive. During POST the SCSI HBA detects both the VS160 tape drive and the SuperLoader3. However, Windows 2008 Device Manager does not discover the SuperLoader3. ISV applications are not able to properly configure and access the library.

Cause:

With Windows 2008 the Ultra320 SCSI HBAs (i.e. Adaptec 39320A) utilized Microsoft STORport driver. The STORport driver issues a REPORT_LUNS and assumes the target device supports HISUP or a hierarchal reporting format (defined in SAM SCSI specification). However, the VS160 tape drive does not claim support for HISUP and uses a non-hierarchal reporting format; therefore, the operating system ignores the LUN attached library. On the other hand, the Adaptec Ultra160 HBA utilizes the SCSIport driver, which checks standard inquiry data from each attached target for HISUP support and will scan all LUNS if the target does NOT advertise support for HISUP. Since the STORport driver does not employ the same logic as the SCSIport driver, it fails to recognize the library as a valid target. Problem does not occur with other tape devices in the SuperLoader 3 (only the V4 and VS160 drives do not support HISUP). Problem does not occur with Windows 2003 or with 160 SCSI HBAs. Ref PCR 18020

Solution:

These are the two options for resolving this issue:

Switch to Windows 2003 which uses SCSIport driver with SCSI Ultra320 HBAs.
Switch to Ultra160 SCSI HBA using SCSIport driver.
***************************************

Problem is, I cannot find a U160 card to work with the HP Proliant ML115 Server, and I have the server completely configured and operating on Server 2008 already.  I have searched and cannot find a way to change the driver from StorPort to SCSIport.

Any suggestions?

Thanks again
0
 
honmapogCommented:
Do you see a "Medium Changer" device in the OS?
If not, it's not a Backup Exec problem. Make sure to get a Medium Changer visible in Windows Device Manager first. Is there a configuration in the HBA to configure the card for Multi-LUN? Make sure it  is enabled if it exists.

If you do see a "Medium Changer" in the OS, then have a look in Windows Device Manager under non-plug and play drivers (have to enable viewing hidden devices to see that branch). Make sure that you have a "SCSIChanger" device driver loaded.

More info in http://seer.entsupport.symantec.com/docs/255501.htm.

Let us know how you get on.
0
 
Icehand03Commented:
I ran into the same problem just today. I was migrating my Backup Exec 12.5 to a 2008 server and it would only show the drive and not the library. I resolved the problem by going to the LCD menu  "Configuration -> Change Mode" in that menu I selected "random". After the power cycle I restarted the server and sure enough there was the library. I did have to install drivers once it was up and running by going into the device page. Hope this helps.



0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
TheMetalicOneAuthor Commented:
Thanks Icehand, Unfortunately, the library does not show up in backup exec under any mode.  I have tried both Random and Sequantial.

The search continues for me.
0
 
TheMetalicOneAuthor Commented:
Turns out the issue is Microsoft has messed with the way things work.  lol

The Ultra320 Driver that Microsoft puts into Server 2008 apparently just wont allow for this to work.  Therefore the combination of Ultra320, Server 2008 and DLT Autoloader will never work regardless of the effort.  I had to buy a Ultra160 card and put it in the server for this to work.   Thanks for your help anyways.  
0
 
OuttaCyTECommented:
I found a solution to this and it is working on my production site.

I have an Adaptec 29320LPE card and the microsoft driver would not detect the media changer device.  The problem was the StorPort driver portion of the Microsoft offering did not work the same way as the ScsiPort driver of old.  Consequently, as TheMetalicOne reports above, the media changer device will never be reported as present.

The solution was to convince 2008 R2 to take the Adaptec driver for 2003 64 bit.

This proved to be difficult as I could not install the older driver as there was one present.  I could not uninstall the driver and then install a different one as it required a reboot and when I rebooted, the 2008 driver loaded.

There should be a way to prevent automatic load of a driver, but I could not figure it out so I decided to break the 2008 driver so it would not load.  Being the cautious type, I took a VM snapshot of the system and tried various methods of removing the driver.  Eventually I found a method using a Windows PE environment whereby I could hunt down the 2008 driver (mine was adpu320.sys) and remove it.  Upon reboot, the system could not find a match as I had removed all of the adpu320 parts (sprinkled everywhere) and so the automatic driver install failed.

Once I had it failed, I could then update the driver using the 2003 64 bit drivers.  Upon reboot the media changer was there and I could load the Backup Exec drivers for the media changer and the tape drive.

It's been working beautifully ever since.

Why, Microsoft, did this have to be so hard to do?

-Desperate enough to hack,
-g
0
 
FAFCUCommented:
Icehand's suggestion was the spot-on solution for our situation involving the Superloader 3 on Windows 2008 R2 64-bit. The Superloader's tape drive was showing in Device Manager, but not the tape library. In Backup Exec 2010, we could see both the library and the tape drive, but the library did not report the presence of any tapes.

Once we switched to "random" rather than "Sequential" in the tape library's web-based configuration utility, a restart of the loader and the server delivered the goods. With the media changer showing in Device Manager, we installed the Quantum-supplied drivers and all was well. Thanks, Icehand!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.