SBS 2003 OWA gives normal login screen but then gives a HTTP 500 error after login

This morning OWA and OMA were "not working". Re-ran the wizard for Internet and Email setup, unchecked the Require SSL and Enable Forms Based Authentication. Seemed to be working Ok from IE and iPhone. Now, they are both down again. Have spent considerable time looking through here for the appropriate answer and each time I think I have it fixed, one or the other stops working.

Any help would be greatly appreciated.

-Steve
SCSSpikeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SCSSpikeAuthor Commented:
To be a little more specific about what I am dealing with, here is a sample of the URL:
Original Link in IE: https://mail.company.com/exchange
After you click on the bookmark, the Address turns to this: https://mail.company.com/exchweb/bin/auth/owalogon.asp?url=https://mail.company.com/exchange&reason=0
After you click Logon, it chages to this but with a HTTP500: https://mail.company.com/exchweb/bin/auth/owaauth.dll
If I manually change that last address to: https://mail.company.com/exchange
then it lets me into the normal OWA page with all my mail and folders.
I know this has to be IIS related and possibly a DUH fix, but I can't find the issue.
Thanks for any help.
0
svgnmlCommented:
I seem to remember this from a few years back.
From a command prompt run the following
c:\windows\system32\regsvr32 scrrun.dll
Then after it registers, restart IIS with the command IISRESET

Now try to log in to OWA again.
0
SCSSpikeAuthor Commented:
The .dll registered successfully and I reset IIS but the HTTP500 error remains.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

svgnmlCommented:
Open Exchange System Manager and drill down to protocols under the Exchange server
Open the HTTP protocol, you should see the Exchange Virtual Server.
Right click on this and select properties
Go to settings, the box should be ticked and the compression should be high.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shreedhar EtteCommented:
Hi,

Have you rebooted the server? If yes, got to http://support.microsoft.com/kb/829167

Else reboot the server first and check OWA.

Problem still persists then refer http://support.microsoft.com/kb/829167

Hope this helps,
Shree
0
SCSSpikeAuthor Commented:
Not sure why I read so many articles telling me to make sure that Forms Based Authentication was turned OFF, but I'm just glad it works now.
Thanks for all the help.

Cheers.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.