Out of Office Assistant not working

Hi!
I have been troubling with OOF at a customer for a long time. I had the same problem on my private SBS server (we are both running SBS 2007), and i solved it.
I have done the same at my customer, and Autodiscover it working.

The results from Test-Email Autoconfiguration can be seen in attached image.
The log of the test is just three lines. It found Autodiscover, it started and succeeded.

Our goal is to use https://remote.domain.no/... as our URL in all our web/exchange related services.
Our Certificate is purchased from Godaddy and has "remote.domain.no" assigned to it.

The URL's for EWS, Autodiscover, OAB and OOF seems to be set corrrect.
Unified Message Service URL is still set to old URL but its like that on my own server too, and its working here. Is this URL important and how do i change it?

Internal DNS is set up with a single A-record pointing remote.domain.no to internal server IP.

I have used http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_25274704.html
and
http://exchangechronicles.blogspot.com/2008_04_01_archive.html

as sources for my tests and changes.

This is the second Question from me on this subject, but i have requested a deletion of the previous because it got off at the wrong foot and i didnt have enough time to follow up.

Can you help me solve this? Im sure it cant be much left.

testing-Outlook.jpg
lurerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BusbarSolutions ArchitectCommented:
can you s[post the output of:
Get-WebServicesVirtualDirectory | Select name, *url* | fl
0
lurerAuthor Commented:
[PS] C:\Windows\System32>Get-WebServicesVirtualDirectory |fl


InternalNLBBypassUrl          : https://ntb01.ntbdom.local/EWS/Exchange.asmx
Name                          : EWS (SBS Web Applications)
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated, Basic}
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated, Basic}
BasicAuthentication           : True
DigestAuthentication          : False
WindowsAuthentication         : True
MetabasePath                  : IIS://NTB01.ntbdom.local/W3SVC/3/ROOT/EWS
Path                          : C:\Program Files\Microsoft\Exchange Server\Clie
                                ntAccess\exchweb\EWS
Server                        : NTB01
InternalUrl                   : https://remote.domain.no/EWS/Exchange.asmx
ExternalUrl                   : https://remote.domain.no/EWS/Exchange.asmx
AdminDisplayName              :
ExchangeVersion               : 0.1 (8.0.535.0)
DistinguishedName             : CN=EWS (SBS Web Applications),CN=HTTP,CN=Protoc
                                ols,CN=NTB01,CN=Servers,CN=Exchange Administrat
                                ive Group (FYDIBOHF23SPDLT),CN=Administrative G
                                roups,CN=First Organization,CN=Microsoft Exchan
                                ge,CN=Services,CN=Configuration,DC=ntbdom,DC=lo
                                cal
Identity                      : NTB01\EWS (SBS Web Applications)
Guid                          : c70ffd84-422d-46ce-b32d-2e8044f9c3cf
ObjectCategory                : ntbdom.local/Configuration/Schema/ms-Exch-Web-S
                                ervices-Virtual-Directory
ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServices
                                VirtualDirectory}
WhenChanged                   : 24.04.2010 09:31:00
WhenCreated                   : 09.02.2010 19:17:38
OriginatingServer             : NTB01.ntbdom.local
IsValid                       : True
0
lurerAuthor Commented:
The command i used was Get-WebServicesVirtualDirectory |fl
as i havent used any selections. This is a SBS server and therefore everything is on one server and IIS.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Shreedhar EtteCommented:
Hi,

Are you using a 3rd party SAN/UCC certificate?

Post the out of below commands:
Get-ClientAccessServer | fl

Get-OABVirtualDirectory | fl

---------
Shree
0
BusbarSolutions ArchitectCommented:
Hi Lurer,
the configuration is correctI believe that you have the name remote.domain.no in the certificate, can you confirm that.
so the issue in access the above url, can you verify that you can access it from a client internally and externally using IE.
@shreedhar,
this is an OOF error, OAB has nothing to do with it
0
lurerAuthor Commented:
[PS] C:\Windows\System32>Get-ClientAccessServer |fl


Name                                               : NTB01
OutlookAnywhereEnabled              : True
AutoDiscoverServiceCN               : NTB01
AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri    : https://remote.domain.no/autodiscover/Autodisc
                                 over.xml
AutoDiscoverServiceGuid            : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
AutoDiscoverSiteScope               : {Default-First-Site-Name}
IsValid                                          : True
OriginatingServer                      : NTB01.ntbdom.local
ExchangeVersion                    : 0.1 (8.0.535.0)
DistinguishedName                    : CN=NTB01,CN=Servers,CN=Exchange Administrative
                                  Group (FYDIBOHF23SPDLT),CN=Administrative Gro
                                 ups,CN=First Organization,CN=Microsoft Exchang
                                 e,CN=Services,CN=Configuration,DC=ntbdom,DC=lo
                                 cal
Identity                       : NTB01
Guid                           : 574489ea-6680-4bea-b962-2ae698f63c66
ObjectCategory                 : ntbdom.local/Configuration/Schema/ms-Exch-Exch
                                 ange-Server
ObjectClass                    : {top, server, msExchExchangeServer}
WhenChanged                    : 09.02.2010 19:19:38
WhenCreated                    : 09.02.2010 19:12:37
0
lurerAuthor Commented:
remote.domain.no is of course not our actual domain, but i use the correct one in Exchange and in the Certificate.
The Certificate is purchased at Godaddy and when im logged on on a local computer i can access http://remote.domain.no/owa, and it also accepts the certificate as a 3rd party signed certificate. Its no warnings in IE etc.
@busbar: Is there any other URL's you think i should try?

0
BusbarSolutions ArchitectCommented:
autodiscover.domain.no, if your clients are not joined to the domain or accessing the OOF externally.

what is the error and how it occurs when you try to configure oof
0
Shreedhar EtteCommented:
Hi,

Exchange is not updated with the service pack 2. Hence request you to update it with service pack 2.

Download Url:
http://www.microsoft.com/downloads/details.aspx?FamilyID=4c4bd2a3-5e50-42b0-8bbb-2cc9afe3216a&displaylang=en

After that update it with Update Rollup 2 for Exchange 2007 Service Pack 2
Download Link: http://www.microsoft.com/downloads/details.aspx?FamilyID=fa83be11-9d5e-47bc-9a51-a10986f22928&displaylang=en

Hope this helps,
Shree
0
lurerAuthor Commented:
The clients are all joined to the internal domain.
The error i get is in norwegian, but its the same as most get with this problem.
Something like: "Can not show Out of Office settings because the server is not available. Try again later."

This show up when i go to Tools - Out of office assistant in Outlook 2007.

It works of course through OWA. It always did.
When the server was new we first wanted to use mail.domain.no as our host and created a certificate for it. OOF did work then, but in the process of doing something else this certificate stopped working like it should and i couldnt remove and add it again without errors. This is when we decided to create this new Certificate. This was already months ago.
It shouldnt have anything to do with the problem, as URLs are correct as far as i can see.
0
BusbarSolutions ArchitectCommented:
that is strange
try the SP2 trick but I don't believe that it is the issue.
do you have any proxy in the IE
0
lurerAuthor Commented:
Ahh, so there is such things as updates and service packs? hehe. I really didnt think of the fact it might miss anything there. Im downloading SP2 now.
They are not using proxy. This is basically a SBS 2007 server and they have 5 clients.. So its a very small setup and nothing fancy in any way.
0
BusbarSolutions ArchitectCommented:
try it and hopefully it will be resolved
0
Shreedhar EtteCommented:
Hi,

As this SBS 2008,

Refer this article:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;973862

--------
Shree
0
Shreedhar EtteCommented:
To upgrade a server to Exchange 2007 SP2 from the command line

At a command prompt, connect to the AMD64 or I386 directory of the Exchange 2007 SP2 media location, and then run Setup.com /mode:upgrade. Accept all default options when you perform the steps from the command line

Hope this helps,
Shree
0
lurerAuthor Commented:
SP2 installed and server rebooted. No change.
When i try to access OOF URL: https://remote.domain.no/EWS/Exchange.asmx in IE it asks me for username and password for the remote.domain.no site.
I enter Admin credentials and i come to this page: https://remote.domain.no/EWS/Services.wsdl
It basically displays a XML code or something. Is it supposed to be like that?

So its still like before the SP2.
0
BusbarSolutions ArchitectCommented:
well the final resoort will be resetting the EWS virtual directory
get-webservicesvirtualdirectory | remove-webservicesvirtualdirectory.
then follow the steps in this article to create a new one
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lurerAuthor Commented:
Is there any unwanted consequences by doing this?
And which article?
0
BusbarSolutions ArchitectCommented:
0
lurerAuthor Commented:
This is the result after removing and recreating WebServicesVirtualDirectory:


[PS] C:\Windows\System32>Get-WebServicesVirtualDirectory |fl


InternalNLBBypassUrl          : https://ntb01.ntbdom.local/EWS/Exchange.asmx
Name                          : EWS (SBS Web Applications)
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
BasicAuthentication           : False
DigestAuthentication          : False
WindowsAuthentication         : True
MetabasePath                  : IIS://NTB01.ntbdom.local/W3SVC/3/ROOT/EWS
Path                          : C:\Program Files\Microsoft\Exchange Server\Clie
                                ntAccess\exchweb\EWS
Server                        : NTB01
InternalUrl                   : https://remote.domain.no/EWS/Exchange.asmx
ExternalUrl                   :
AdminDisplayName              :
ExchangeVersion               : 0.1 (8.0.535.0)
DistinguishedName             : CN=EWS (SBS Web Applications),CN=HTTP,CN=Protoc
                                ols,CN=NTB01,CN=Servers,CN=Exchange Administrat
                                ive Group (FYDIBOHF23SPDLT),CN=Administrative G
                                roups,CN=First Organization,CN=Microsoft Exchan
                                ge,CN=Services,CN=Configuration,DC=ntbdom,DC=lo
                                cal
Identity                      : NTB01\EWS (SBS Web Applications)
Guid                          : 96a7fb99-a270-4748-a47d-f15b14fff9c4
ObjectCategory                : ntbdom.local/Configuration/Schema/ms-Exch-Web-S
                                ervices-Virtual-Directory
ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServices
                                VirtualDirectory}
WhenChanged                   : 25.04.2010 00:49:05
WhenCreated                   : 25.04.2010 00:49:05
OriginatingServer             : NTB01.ntbdom.local
IsValid                       : True



Have just added InternalURL for now. Still no effect on OOF in Outlook.

To me settings and URLs looks to be correct all over. It almost looks to be a corrupt database or something like that, that prevents me in doing the changes to make it work. I just dont know..
0
BusbarSolutions ArchitectCommented:
one last thing to test.
can you enter the server name as the internal URL, assign a certificate to IIS that has the name and try it
0
lurerAuthor Commented:
This morning i got a phone call from the client saying they couldnt use their iPhones to check emails.
I connected to the server and noticed IIS was not running. I started the service, and Voila!!
OOF is now working.
@busbar, i did not try your last suggestion, so it must have been the removal and recreating of the EWS virtual directory that made the difference. When you try to restart IIS from within IIS, it times out, and i must have forgotten to start the service manually this last time.

I'll accept your suggestion with EWS as Solution busbar, but i have to point out that for anyone trying this in the future. Just remove and recreate the Autodiscover and EWS virtual directories right away. It will probably save you some time.

Thanks for all help!
0
lurerAuthor Commented:
Dont just recreate EWS, but also Autodiscover..
0
CoSmismgrCommented:
Recreating the Virtual Directories solved this issue for me as well. I have a wildcard SSL certificate and use external URL's for everything, OOF was inaccessible internally and this was the only thing that worked!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.