Ubuntu Server 9.10 Won't Talk To Gateway When Using Static IP

When i set my nic to run in dhcp mode, I can pull an address and ping anything and everything i want to... gateway, google, whatever.  But, when I set it to have a static IP, I can ping other hosts in my IP range, but NOT the gateway or anything on the other side (the whole world).
Here is my static IP info.
/etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 10.1.100.90
netmask 255.255.255.0
network 10.1.100.0
broadcast 10.1.100.255
gateway 10.1.100.1

Please, help me out!
LVL 1
Digital_SkreamAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hemmiCommented:
Are you absolutely sure 10.1.100.1 is the correct address of your gateway?
Did you ping the gateway by it's name or by it's ip address?
What is the output of:
ifconfig
route -n
cat /etc/resolv.conf

Next: use once again DHCP and again give the result of:
ifconfig
route -n
cat /etc/resolv.conf
0
Digital_SkreamAuthor Commented:
To answer your question, yes I am certain that 10.1.100.1 is my gateway.
I pinged the gateway by its ip address.  The result is 100% packet loss.

Ok, here's the outputs from when I have a static Ip set:
ifconfig
---------
eth0      Link encap:Ethernet  HWaddr 00:0c:29:cf:67:60
          inet addr:10.1.100.90  Bcast:10.1.100.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fecf:6760/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2144 errors:0 dropped:0 overruns:0 frame:0
          TX packets:721 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:180633 (180.6 KB)  TX bytes:67859 (67.8 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

route -n
----------
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.1.100.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         10.1.100.1      0.0.0.0         UG    100    0        0 eth0

resolv.conf
--------------
domain mydomain.local
search mydomain.local
nameserver 10.1.100.60
nameserver 10.1.100.66



Now ehre are the outputs from the same commands when using DHCP

ifconfig
---------
eth0      Link encap:Ethernet  HWaddr 00:0c:29:cf:67:60
          inet addr:10.1.100.101  Bcast:10.1.100.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fecf:6760/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2198 errors:0 dropped:0 overruns:0 frame:0
          TX packets:751 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:185328 (185.3 KB)  TX bytes:71240 (71.2 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

route -n
----------
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.1.100.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         10.1.100.1      0.0.0.0         UG    100    0        0 eth0

resolv.conf
--------------
domain mydomain.local
search mydomain.local
nameserver 10.1.100.60
nameserver 10.1.100.66
0
hemmiCommented:
Is the gateway also the DHCP server? What type of gateway?
Could it be, that the gateway will not accept traffic, unless it explicitly opens access for a certain ip address? I.e. you act as a dhcp client, the gateway gives you e.g. 10.1.100.101 as address and opens access for 10.1.100.101.

Is there a possibility for another machine to have your static ip 10.1.100.90 in use?

Open two text terminals:
On one run
sudo tcpdump -n -i eth0 -vv
while you run ping on the other.
What is the output of tcpdump while you ping?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Digital_SkreamAuthor Commented:
Ok, I solved it.
1.) The router was a D-Link DIR-628.
2.) I had turned off SPI on the router a few months ago in response to another issue.
3.) The linux box is running as a VM in ESXi 4.1
4.)  Somehow, the router had its SPI turned back on. (I'm currently questioning my officemates)
5.) Due to the way ESXi insulated its VMs, the SPI on this particular router was rejecting the ICMP from the VM when it was running as a Static IP.

Still not sure why Static vs. DHCP  made ANY difference, as the DHCP sserver is a Windows box on the network, but hey at least it works now after turning SPI off again.
I will award you the points as the only poster who tried to help.
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.