Resetting security on WUAUSERV and BITS services

I must keep resetting the security on the WUAUSERV and BITS services each time the computer restarts. I have to run the SC sdset <service> <security string> command for both services before the services, which are set to Automatic Startup, will run successfully. If not, I receive the error as shown below.

My current configuration is a Win 2k3 Enterprise R2 WSUS that replicates with the MS server to pull updates and all my Win XP clients connect to the local server.

Is there any way to fix this problem once and for all?
WUAUSERV-Error.png
DirkaDanAsked:
Who is Participating?
 
DonNetwork AdministratorCommented:
also check the comments here, as it may be your gpo's that keep resetting the permissions.

http://www.windowsreference.com/windows-xp/error-0x80004015-when-automatic-updates-fail-with-wsus-server/
0
 
DonNetwork AdministratorCommented:
0
 
DirkaDanAuthor Commented:
Thank you. I'll try modifying our GPO and see if that corrects the problem.
0
 
DirkaDanAuthor Commented:
It was the GPO security settings. The only one that was not in there was authenticated users. I changed the GPO, ran a gpupdate/force, restarted, and both services came up without any issue.

Thanks for your help
0
 
DonNetwork AdministratorCommented:
Glad to help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.