Event ID 64 – Failed to read and update the Outlook Web Access configuration settings after re-create the Outlook Web Access-related virtual directories

I have tried to re-create the Outlook Web Access-related virtual directories with this web site http://www.fots.nl/index.php/archive/event-id-64-failed-to-read-and-update-the-outlook-web-access-configuration-settings/
 because of a problem of blank page to access OWA with Exchange 2010

When I type the command : remove-OWAVirtualDirectory -identity “\owa (default web site)” I have this error : Objet server.company.local\owa (default web site) not found

When I type the command : new-OWAVirtualDirectory “owa (default web site)” I have this error : The virtual directory "owa" already exists

In Exchange Management I have lost Outlook Web App in Client Access

How to repair my virtual directory OWA?
LVL 1
TchekboAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shreedhar EtteCommented:
Use these command:

Remove-OwaVirtualDirectory "owa (default web site)"

New-OwaVirtualDirectory -name "owa" -WebSiteName "Default Web Site" –InternalURL https://internalURL/owa -ExternalURL https://externalURL/owa

Hope this helps,
Shree
0
AkhaterCommented:
you have a problem with the syntax there is no need for the "\" in : remove-OWAVirtualDirectory -identity “\owa (default web site)”


If you have only one exchange CAS server you can do it simply by

get-OWAVirtualDirectory | remove-OWAVirtualDirectory

or  you need to issue a remove-owavirtualdirectory "server.company.local\owa (default web site)"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TchekboAuthor Commented:
I have the same error with :
- Remove-OwaVirtualDirectory "owa (default web site)"  --> not found
- New-OwaVirtualDirectory -name "owa" -WebSiteName "Default Web Site" –InternalURL -https://internalURL/owa -ExternalURL https://externalURL/owa --> "owa" already exists
- get-OWAVirtualDirectory | remove-OWAVirtualDirectory  
- remove-owavirtualdirectory "server.company.local\owa (default web site)" --> not found

If I type the command get-OWAVirtualDirectory, I have nothing

I have always the problem
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

AkhaterCommented:
then you have a problem with you IIS metabase, you need to download the metabase explorer to fix this issue

get the metabase explorer from http://support.microsoft.com/kb/840671


install it then start Metabase Explorer. To do this, click Start, All Programs, IIS Resources, and then click Metabase Explorer.

Expand the LM key, right-click the DS2MB key, and then click Delete.
0
TchekboAuthor Commented:
I have installed Metabase Explorer and Expand the LM key, but I have not the DS2MB key.

Screen Print here : http://dl.free.fr/tutVsQxLE

0
AkhaterCommented:
it would be hard to tell without having IIS metabase to play with at hand ATM

try expanding the w3svc "folder" or the IISadmin one can you find OWA virtual directory anywhere ?
0
TchekboAuthor Commented:
I have OWA virtual directory in W3SVC / 1 / ROOT / owa

http://dl.free.fr/bJpx0LAAy
0
AkhaterCommented:
great delete it !
0
TchekboAuthor Commented:
Ok I delete OWA virtual directory from metabase explorer.

I type the command New-OwaVirtualDirectory -name "owa" -WebSiteName "Default Web Site" –internalURL https://internalURL/owa -ExternalURL https://externalURL/owa

Or the command New-OWAVirtualDirectory “owa (default web site)”

And I have this error :

ID Event : 8
(PID 8096, thread 73) The task New-OwaVirtualDirectory launched an exception not managed during the treatment of the recording of the index 0. Exception : Microsoft.Exchange.Management.Common.WmiException: An exception WMI occurred on the server ' server.company.local ': the service cannot be started because it is deactivated or because no activated ring peripheral is associated with her.(Exception de HRESULT : 0x80070422) ---> System.Runtime.InteropServices.COMException (0x80070422): The service cannot be started because it is deactivated or because no activated ring peripheral is associated with her
(Exception de HRESULT : 0x80070422)
   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at System.Management.ManagementScope.InitializeGuts(Object o)
   at System.Management.ManagementScope.Initialize()
   at System.Management.ManagementObject.Initialize(Boolean getObject)
   at System.Management.ManagementObject.Get()
   at Microsoft.Exchange.Management.Common.WmiWrapper.GetManagementObject(String computerName, String managementPath)
   --- Fin de la trace de la pile d'exception interne ---
   at Microsoft.Exchange.Management.Common.WmiWrapper.GetManagementObject(String computerName, String managementPath)
   at Microsoft.Exchange.Management.Common.WmiWrapper.GetDirectoryObject(String computerName, String dirName)
   at Microsoft.Exchange.Management.Common.W      miWrapper.IsDirectoryExisting(String computerName, String dirName)
   at Microsoft.Exchange.Management.Metabase.VirtualDirectoryPathExistsCondition.Verify()
   at Microsoft.Exchange.Management.SystemConfigurationTasks.NewOwaVirtualDirectory.InternalValidate()
   at Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()
0
AkhaterCommented:
did you try to restart the server ? restart IIS?
0
TchekboAuthor Commented:
I have restart the server and IIS et the problem is the same. Same error.
0
AkhaterCommented:
are you running 2008 sp2 or r2 ?

what exchange rollup ?
0
AkhaterCommented:
also please make sure that Windows Update and Windows Module Installer services are enabled and started
0
TchekboAuthor Commented:
It's 2008 R2.

I have start the Windows Management Instrumentation service and the command New-OwaVirtualDirectory -name "owa" -WebSiteName "Default Web Site" –internalURL https://internalURL/owa -ExternalURL https://externalURL/owa WORK !

Now when I go to the address to https://server/owa, I have a blank page instead of the authentification.

I have a second problem with blank page in OWA
0
AkhaterCommented:
I am afraid this is a totally different issue, I would suggest you open another question for it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.