Cannot open registry key 'HKLM\SYSTEM\CurrentControlSet\Services\MSSQL$xxx\Performance'. SQL Server performance counters are disabled

The above error message always appears when I install a new instance of sql server express 2005.

How do I enable performance counters.

I have tried unlodctr, lodctr

What keys is it expecting

adimitAsked:
Who is Participating?
 
adimitAuthor Commented:
note: also had to give full directory rights to the service account. Full directory rights were applied to the sql server directory.
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
>> SQL Server performance counters are disabled

Performance counters for SQL Server are disabled in your machine.
Kindly check for Disable Performance Counters key value under HKLM\SYSTEM\CurrentControlSet\Services\MSSQL$xxx\Performance path which should have value as 1 (since counters are disabled).
Either delete that key or change it to 0 to enable Performance counters in that machine.
More info here:

http://blogs.msdn.com/psssql/archive/2009/03/03/how-it-works-almost-everything-you-wanted-to-know-about-the-sql-server-2005-2008-performance-counter-collection-components.aspx
http://ferventcoder.com/archive/2008/08/10/possible-performance-counter-corruption-or-performance-counters-are-just-disabled.aspx
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
adimitAuthor Commented:
the performance key wasn't in the registry error. The problem was with security rights.  couldn't use the local service account.  Assigned a local administrator account that was also a domain user as the account to run the sql service for that instance. this solved the problem.
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
>> couldn't use the local service account

You should use Local System or some Domain user with Administrative rights as the Startup account for SQL Server ( as a general practice)
And glad to see you got it fixed..
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
>> Full directory rights were applied to the sql server directory.

Just add your domain user as part of SQLServer2005MSSQLUser$InstanceName which should suffice..
Another workaround is to grant Directory permissions explicitly to your domain user.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.