Proxy addresses with Citrix Secure Gateway

I am trying to proxy ssl through my Citrix Secure Gateway to provide sync capabilities for smart phones.  When I make the following entry into the httpd.conf I get a 404 page not found when attempting to hit the Citrix web interface.  Am I missing something?   The url's do work if entered manually into the iexplorer.


...
       # This rule states that Secure Gateway won't proxy anything that starts with /error
        ProxyPass /error !
 
 # Begin Custom Proxy Entry

        ProxyPreserveHost On
      SSLProxyEngine on

      # Reverse Proxy ActiveSync
      <Location /Microsoft-Server-ActiveSync>
            ProxyPass https://host.domain.local/Microsoft-Server-ActiveSync
            ProxyPassReverse https://host.domain.local/Microsoft-Server-ActiveSync
      </Location>

      <Location /OMA>
            ProxyPass https://host.domain.local/OMA
            ProxyPassReverse https://host.domain.local/OMA
      </Location>

      # Outlook Web Access
      <Location /Exchange>
            ProxyPass https://host.domain.local/Exchange
            ProxyPassReverse https://host.domain.local/Exchange
      </Location>
      <Location /exchweb>
            ProxyPass https://host.domain.local/exchweb
            ProxyPassReverse https://host.domain.locall/exchweb
      </Location>
      <Location /Public>
            ProxyPass https://host.domain.local/Public
            ProxyPassReverse https://host.domain.local/Public
      </Location>
 
#--End custom proxy

        # Reverse Proxy Web Interface
        <Location />
                ProxyPass http://localhost/
                ProxyPassReverse http://localhost/
        </Location>
 
        # Used by HTTP custom Log Setting
        SetEnvIf nolog ^$ LOG_HTTP=1
...
dandnetAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Daniel BorgerSenior Citrix Engineer- CCEECommented:
Has your web interface been configured to respond to SSL requests?

From the Computer Management console, right-click the Web site on which you want to enforce SSL and click Properties.
Click the Web Site tab. In the Web Site Identification section, verify that the SSL Port field is populated with the numeric value 443.
Click Advanced. You should see two fields. The IP address and port of the Web site should already be listed in the Multiple identities for this web site field. Under the Multiple SSL Identities for this web site field, click Add if port 443 is not already listed. Select the server's IP address, and type the numeric value 443 in the SSL Port field. Click OK.
0
Daniel BorgerSenior Citrix Engineer- CCEECommented:
http://support.citrix.com/article/CTX711855

Also are there any errors in the logs for Web interface,CSG Logs or event viewer that would direct us to the resolution?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.