Outlook 2007 not changing exchange 2010 server with mailbox move

I have been struggling with this for some time. Just completed an exhcange 2007 to exchange 2010 migration. what we did was create a temporary 2010 server move all he mailboxes and PFs to it, uninstall and wipe the current 2007 server and then install 2010 and move all the mailboxes and PFs over to it. When we did the inital 2007 to 2010 transition the outlook clients had no issue repointing themselves to the new servers, however when moving from the one 2010 server to the other some of the clients are not switching automatically. However, if I manually repoint them it works fine. So, can someone tell me what I am missing, I need to take the temporary server out of production. Thanks in advance
bamill12000Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkhaterCommented:
what is happening is that both your exchange server have the CAS role installed (I guess) and in exchange 2010 clients connect to the CAS server and not to the mailbox server like previous versions.

So outlook can still connect to its mailbox without switching.

0
bamill12000Author Commented:
so, do I uninstall the CAS role on the old server? And then it will move over?
0
AkhaterCommented:
go to powershell and issue a

get-mailboxdatabase | fl *rpc* what is the result.

0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

bamill12000Author Commented:
it shows both servers as RPCClientAccessServers
0
AkhaterCommented:
it shows both on both databases ?


if so use

set-mailboxdatabase "new mailbox" -RPCClientAccessServers newserver

0
bamill12000Author Commented:
it shows both listed when I run the command on either server. It does not list the database nexto it.... output looks as follows

RpcClientAccessServer : Server 1

RpcClientAccessServer : Server 2
0
AkhaterCommented:
ok let's try this once more

get-mailboxdatabase | fl name,*rpc*

mailbox 1 is on server 1 and mailbox 2 is on server 2 right ?
0
bamill12000Author Commented:
yes on the mailbox location....

rpc for mailbox 1 is server 1 and rpc for mailbox 2 is server 2....

should they both be server 2?
0
AkhaterCommented:
let me try to summarize to make sure I am getting the right picture

1. DB1 is on server1
2. DB2 is on server2
3. DB1 RpcClientAccessServer  is server1
4. DB2 RpcClientAccessServer  is server2
5. user1 was moved from DB1 to DB2 but outlook still connecting to server1 however user1 email access is normal. he can send/receive emails and user outlook

am i right ?
0
bamill12000Author Commented:
yep
0
AkhaterCommented:
good can you try to disconnect server1 from the network and restart outlook of user1 ?
0
bamill12000Author Commented:
I have disconnected and the user lost connectivty, and i belive a restart of outlook did not work.... I can try it on monday, if that is the case, what would be the next step
0
AkhaterCommented:
I think (as educated guess) that once the clients cannot connect to server1 anymore they will switch to server2 (not all of them just the ones who's mailboxes are on server2).

If this is the case then you have nothing to worry about, once you move all your mailboxes you would be safe
0
bamill12000Author Commented:
ok...

All of the mailboxes have been moved, I will try that.

what do you think the impact would be of changing the rpcclient access server on MB1 to point to Server 2? Cause the same thing?

thanks for the help...
0
AkhaterCommented:
change the rpc client to server 2 can be done, i just can't see the purpose of doing so right now.


please do the test to disconnect server1 and restart outlook for a client who's mailbox is on server 2 asap
0
bamill12000Author Commented:
no dice.

when I shutdown server 1, clients pointed to it do not switch over even with a restart of outlook.
0
AkhaterCommented:
Yes I was afraid this would happen !

I remember vaguely this was my problem when I first installed exchange 2010 and that confirms it! Lucky I was still testing then and noticed I would be better off creating CASArrays for each sites even with only one CAS server for this specific reason.

how many clients are we talking around
0
AkhaterCommented:
please issue Get-ClientAccessServer | fl *aut* and give me the results
0
bamill12000Author Commented:



[PS] C:\Windows\system32>get-clientaccessserver |fl *aut*


AutoDiscoverServiceCN          : Server 1
AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri : https://Server1/Autodiscover/Autodiscover.xml
AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
AutoDiscoverSiteScope          : {Default-First-Site-Name}

AutoDiscoverServiceCN          : Server2
AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
AutoDiscoverServiceInternalUri : https://vbServer2/Autodiscover/Autodiscover.xml
AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
AutoDiscoverSiteScope          : {Default-First-Site-Name}


0
bamill12000Author Commented:
approx 30 users
0
AkhaterCommented:
it should work your autodiscover looks fine what is the result of get-outlook provider ?
0
bamill12000Author Commented:
[PS] C:\Windows\system32>get-outlookprovider

Name                          Server                        CertPrincipalName             TTL
----                          ------                        -----------------             ---
EXCH                                                                                      1
EXPR                                                                                      1
WEB                                                                                       1


[PS] C:\Windows\system32>
0
AkhaterCommented:
yes this is also right, I can't remember the final conclusion I reached when I was in the same situation :s

how long have you kept your outlook trying to connect before you decide it is not connecting ? the process can take a few time to get the Autodicover to kick in.

the clients are joined to the domain right ?
0
bamill12000Author Commented:
yep, they are joined I didn't give it a lot of time 5 minutes...
0
AkhaterCommented:
5 minutes should be enough

if you use the "test email autoconfiguration" in outlook what is the result ?
0
bamill12000Author Commented:
where do I do that from again?
0
AkhaterCommented:
open outlook on  a client CTRL + right click on the outlook icon in the system tray
0
bamill12000Author Commented:
uses OOF is server 1
OAB is server 2

in the log it looks like it is only using server 1 for autodiscover

again, we want it to use server 2
0
AkhaterCommented:
do the same with server1 disconnected will it use server 2?
0
bamill12000Author Commented:
I will have to check later this afternoon... I will get back to you.
0
bamill12000Author Commented:
When I do that I recive a certificate error that says issue 1: "The security cert was issued by a company you have not chosen to trust"

issue 2: the name on the security certis invaild or does not match the site.

this is for autodiscover.domain.com
0
bamill12000Author Commented:
although in the log this time it attempt and find server 2
0
AkhaterCommented:
what is the autodiscover.domain.com record pointing to ?
0
bamill12000Author Commented:
server 2
0
AkhaterCommented:
OK and the client didn't pick up its new config ?
0
bamill12000Author Commented:
correct, I did get the cert error, I don't know if that means anything though
0
AkhaterCommented:
can you make sure that all services on your server 2 set to automatic are started?
0
bamill12000Author Commented:
hmmm... the folowing services are set to auto but not started

edgesync
file distribution
protected service host

the following are set to manual and not started
Imap4
monitoring
server extentsion for windows server backup
0
AkhaterCommented:
these should not affect !

since you are getting the certificate warning then outlook is connecting to the new autodiscover service

can you please give me the xml file generate when you ran "test email autoconfiguration"
0
bamill12000Author Commented:
where would that be located?
0
AkhaterCommented:
when you run it the last tab is called xml

copy / paste it
0
bamill12000Author Commented:
ok... give me a few
0
bamill12000Author Commented:
I can't take down server 1 during biz hours, but this was ran with it up, interesting that it has services still assigned to server 1

<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
  <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <User>
      <DisplayName>USER NAME</DisplayName>
      <LegacyDN>***************************************************
      <DeploymentId>16f09974-2916-4da3-97c9-f8ce0e636133</DeploymentId>
    </User>
    <Account>
      <AccountType>email</AccountType>
      <Action>settings</Action>
      <Protocol>
        <Type>EXCH</Type>
        <Server>server2</Server>
        <ServerDN>/o=DOMAIN/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=Server2</ServerDN>
        <ServerVersion>7380827F</ServerVersion>
        <MdbDN>/o=DOMAIN/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=Server2/cn=Microsoft Private MDB</MdbDN>
        <PublicFolderServer>server2</PublicFolderServer>
        <AD>Domain Controller 1</AD>
        <ASUrl>https://server1/EWS/Exchange.asmx</ASUrl>
        <EwsUrl>https://server1/EWS/Exchange.asmx</EwsUrl>
        <EcpUrl>https://server1/ecp</EcpUrl>
        <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
        <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=<IsOWA>&amp;MsgID=<MsgID>&amp;Mbx=<Mbx></EcpUrl-mt>
        <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
        <OOFUrl>https://server1/EWS/Exchange.asmx</OOFUrl>
        <UMUrl>https://server1/EWS/UM2007Legacy.asmx</UMUrl>
        <OABUrl>http://server2/OAB/201a1996-22c8-4bda-80f6-eaa46bbee1c5/</OABUrl>
      </Protocol>
      <Protocol>
        <Type>WEB</Type>
        <Internal>
          <OWAUrl AuthenticationMethod="Basic, Fba">https://server2/owa/</OWAUrl>
          <OWAUrl AuthenticationMethod="Basic, Fba">https://server1/owa/</OWAUrl>
          <Protocol>
            <Type>EXCH</Type>
            <ASUrl>https://server1/EWS/Exchange.asmx</ASUrl>
          </Protocol>
        </Internal>
        <External>
          <OWAUrl AuthenticationMethod="Fba">https://email.domain.com/owa/</OWAUrl>
          <Protocol>
            <Type>EXPR</Type>
            <ASUrl>https://email.domain.com/ews/exchange.asmx</ASUrl>
          </Protocol>
        </External>
      </Protocol>
    </Account>
  </Response>
</Autodiscover>
0
AkhaterCommented:
this was taken while server1 is online or offine ?
0
bamill12000Author Commented:
online
0
AkhaterCommented:
Ok take it off when you can and test again please
0
bamill12000Author Commented:
If I look on the results pane,
Availability service
OOF URL
Unified Message service are all server 1
0
bamill12000Author Commented:
ok
0
bamill12000Author Commented:
When I do that I get nothing for XML,

results say Autoconfiguration was unable to determine your settings
0
bamill12000Author Commented:
it appears that the autoconfiguration serve is pointed to server 1 and needs to be pointed to server 2....
0
AkhaterCommented:
you did the test again with server1 down ? if yes please give me the xml file
0
bamill12000Author Commented:
I did, it did not spit anything out for xml
0
bamill12000Author Commented:
Autodiscover virtual directory in IIS had been changed not to allow anyomous authentication. Changed it back to allow and now everything works
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.