add new font.ttf file to windows 7?

Hi
I use this code to place a new font in c:\windows\fonts
"FileCopy strSourcePath, strDestanationPath"
It works good in windows xp
But in windows 7
I have err# 75 directory/path access problem(some thing like that)
I was very sure I have administrator authority and the folders property is not read .
Where is the problem please
Mohammad Alsolaimanapplication programmerAsked:
Who is Participating?
 
Rory de LeurConnect With a Mentor Consultant End-User ComputingCommented:
Start your Explorer windows with elevated privileges... (run as administrator)
0
 
☠ MASQ ☠Connect With a Mentor Commented:
Set privileges in HKLM before running as with UAC you'll need elevated rights
Also you might find using the FONTS_FOLDER variable useful as described here (for XP but will work in W7)
http://www.gamedev.net/community/forums/topic.asp?topic_id=386084</P>
0
 
mstrasserConnect With a Mentor Commented:
How to Disable and Turn Off UAC in Windows 7

http://www.blogsdna.com/1815/how-to-disable-uac-turn-off-uac-in-windows-7-beta-1-build-7000.htm

User account control (UAC) a new feature which was introduced in Microsoft windows vista has become more annoying feature. UAC in windows vista is way to protected windows operating system by preventing unauthorized changes to your system. However UAC in Windows 7 is less annoying and more friendlier now.

Windows 7 UAC has option to set level of alerts and notification hence virtually no setting to turnoff or disable UAC in windows 7.well actually the steps for disabling UAC in windows 7 is more or less similar to windows vista.
Thanks to My Digital Life, which has listed four ways to turnoff and disable UAC in windows 7. We are listing two methods from that list which are easier to follow.

Method 1: Disable and Turnoff UAC in Windows 7 from Control Panel
1. Access User Control Panel from Start Menu -> Control Panel -> User Accounts and Family Safety -> User Account

2. Click on
User Account Control settings link.

3. Move the Slider to Never Notify

4. Click OK to make the change effective

5. Reboot.

Method 2: Disable UAC with Registry Editor (Regedit) in Windows 7
1. Run Registry Editor (RegEdit) by typing regedit at command prompt or at startmenu->run

2. Locate following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System

3. Locate the following REG_DWORD value:

EnableLUA

4. Set the value of EnableLUA to 0.

Optional step to suppress UAC permission prompt dialog,

1. Locate the following REG_DWORD value:

ConsentPromptBehaviorAdmin

2. Set the value of ConsentPromptBehaviorAdmin to 0 (optional).

Now Exit from Registry Editor and Restart the computer.

carpe Diem
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
McKnifeConnect With a Mentor Commented:
Hi.
You are using the command line, so the comm. line has to be started elevated.
->hit the start button, type cmd ->cmd.exe will be found ->now press ctrl+shit+enter (or simply rightclick it and select "run as administrator"). Then launch your command.
As I don't think you are using it once at your own computer but rather on many machines, you should use a start script - start scripts run prior to logon and don't need to run elevated.
0
 
ravichandra927Connect With a Mentor Commented:
go to control panel and then go to folder "fonts" the paste the font in the folder its done
0
 
Mohammad Alsolaimanapplication programmerAuthor Commented:
Hi mastrasser,
i use TweakUAC but nothing happen

0
 
Mohammad Alsolaimanapplication programmerAuthor Commented:
Hi, McKnife
"->hit the start button, type cmd ->cmd.exe will be found ->now press ctrl+shit+enter (or simply rightclick it and select "run as administrator"). Then launch your command. "
when i type "type cmd" i got th black ms dose prompt , thin i get confuse
i press ctrl+shit+enter or  rightclick it , but nothing happen to me?
please help
0
 
McKnifeConnect With a Mentor Commented:
Another appoach to get to the elevated command prompt is to rightclick cmd.exe and select "run as administrator". cmd.exe is located in c:\windows\system32.
I thought you would want to use a script or command line. If not, the easiest way is 32138723, simply use explorer and copy these fonts to c:\windows\fonts.
0
 
centervConnect With a Mentor Commented:
How to Install, Remove and Hide Fonts in Windows 7


http://www.7tutorials.com/how-install-remove-and-hide-fonts-windows-7 
0
 
Mohammad Alsolaimanapplication programmerAuthor Commented:
thanks to all of you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.