OWA fails with FBA off but OMA works and vice versa

If Forms Based Authentication is off, then OWA fails but OMA works. When I enable FBA, OWA works and OMA fails. Obviously I need both to work but can't seem to noodle out the correct combination. I have Require SSL unticked and Basic/Windows Authentication ticked under the Virtual Directories in IIS. All was working fine a couple of days ago, it just started failing for some reason. Any insight would be appreciated.
SCSSpikeAsked:
Who is Participating?
 
SCSSpikeAuthor Commented:
Hi, all fixed, the issue was due to the IUSR password not being in synch with ADUC. thanks for all the help, it has been a very long weekend.
Cheers.
0
 
SCSSpikeAuthor Commented:
Update: Currently OMA is functioning and OWA is giving a proper login screen and then after credentials are ented, displays a HTTP 500 error. I posted that very issue as a question on Friday and the fix turned out to be turning on the Forms Based Authentication and setting the compression to High. I was extremely glad when I saw that this indeed fixed the OWA HTTP500 error, but what I did not realize until late last night was that when FBA was enabled, it broke OMA.

Thankfully it is the weekend and users are not really needing the OWA, so I have left FBA unchecked to keep OMA alive. Any help would be appreciated.
0
 
Shreedhar EtteCommented:
Hi,

Refer this article:
http://support.microsoft.com/kb/817379

Hope this helps,
Shree
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
MegaNuk3Commented:
Simply re-running the CEICW on SBS should fix this.

Otherwise refer to the article Shree has posted and go down to the section where it mentions the exchange-oma directory and the ExchangeVDir registry setting.

After running the CEICW, confirm everything is fine, if not then confirm your settings are as per the article.
0
 
SCSSpikeAuthor Commented:
Hi, thanks for the tips. Everything seems to have gone well after following the KB articles steps but now a new problem has come up. OMA is working fine as well as the normal functions of Exchange, local Outlook connections etc. but now when attempting to login to OWA I receive a 440 Login Timeout error message. I was not getting this error before so the issue has changed. Any idea as to what may have caused this behavior?
Thanks.
0
 
MegaNuk3Commented:
turn off FBA press apply then turn it back on again
0
 
MegaNuk3Commented:
make sure "require SSL" is unticked on the Exchange-OMA directory
0
 
SCSSpikeAuthor Commented:
Cycled the FBA and verified that SSL was not enabled on the Exchange-OMA directory. Still getting the 440 error on OWA and OMA is still working.
0
 
MegaNuk3Commented:
thanks for the update, glad it is working again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.