A Netgear WG111 USB WIFI card won't connect

I have a Dell D800 that the onboard wifi card wouldn't stay connected to the router.  I have tried 3 different routers with the same effect.  So I purchased a Netgear WG111 USB wifi card.  I was able to install the software and talk to the WG111,  I am using WPA2/AES on the router.  But the card will find the network and the channel but will not connect.  I don't get an IP address from the router.  My other computers on the router work just fine.
I went the the Netgear site and they told me to go to MS and D/L a security patch.  When I did that I got the message the the current patch that I had was newer than the one trying to install so it stopped.
The next solution was to try WPA or WEP but I thought that both of those were less secure.

Any ideas as to what my next steps should be?

Thanks
elentiniAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MiniDevoCommented:
I had something similar with an older Toshiba. Worked fine once I dropped the router down to WPA. To be honest, unless you're afraid your neighbors are pretty serious code crackers, you'll be fine.
hydrox467Commented:
This has happened to me a couple times and turned out that I had typed the wrong password on the computer to connect to the wireless.

If its not the password, do you have MAC filtering setup on the router? You might need to add your new card to the list if you do.

If neither of those work, then I would agree with MiniDevo that you should try using WPA and seeing if you can connect then.
edbedbCommented:
I would try removing the netgear wireless utility and use the standard Windows Zero Configuration.
If the drivers get removed with the netgear utility, restart the computer and have the Driver Wizard search the Netgear CD for drivers.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
elentiniAuthor Commented:
I went through the process but ran into the same issue.  But on the 2nd reboot it worked.  So I am not sure what caused the problem
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.