SSMS 2008 very slow to show my databases


We've been running a clustered system with 1200+ databases for some time now.
SQL Server is 2005 Entreprise running on 32-bit (upgrade from SQL 2000)

Since we upgraded our SSMS ( Only the SSMS, not the Database-Server ) from 2005 to 2008, loading all the databases takes 10-15 minutes. Before on the same server but with SSMS 2005 it took 30 seconds max and you did see them appear while they were loading.

Now it's like before in the Entreprise Manager where it took 10-15 minutes too.
It looks like next to doing a catalog, he also opens every database.
I've disabled IntelliSense to no effect.

Is this a known issue and is there a solution for?

Sven Peeters

PS : SSMS is still SP0, will install SP1 in a few weeks.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sorry just to confim...

you have a SQL Server 2005 instance on a clustered server .. running 1200+
(in how many instances?)
(what hardware/OS)
(which fixpack...)
(at what compatability level are the databases...)

and you have now installed SQL server 2008 SSMS SP0..
is this on the same server?
icemokkaAuthor Commented:

SQL Server 9.0.3042 on Server 2003 32bit with AWS enabled, default instance
Primary server HP DL580 G5 with 4 CPU's 20Gb
Failover server HP DL 380 G3 with 2 CPU's 8Gb
Compatibility level is 90 on all databases.

SSMS SP0 is installed on an separate application server, I never install an SSMS on the database server itself.

Same server, same application server but SSMS 2005 and the refresh is in 30 secs.
One thing that can slow down SSMS loading is the Internet Explorer component (i.e. the bit that renders SSRS reports) searching for revoked certificates. Assuming your SQL servers have no Internet access (I hope not!) you may want to try the following trick. This works for at our place so hopefully it may help you:

Open Internet Explorer on the same box that the slow SSMS is installed on. Go to Tools > Internet Options > Advanced > Security sub-heading. Disable the 'Check for publisher's certificate revocation' box and hit Ok. Quit IE and then try to load SSMS again.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Try this as well

From the menu, go to

Go to Environment\General section
For At Startup option => Open empty environment
icemokkaAuthor Commented:
Hi gothamite & cyberkiwi,

It's not the startup of SSMS that is slow (or slower then 2005).
Expanding the 1200+ databases is the problem.

Appears to be fixed for R2.  FYI R2 has been RTM on 21/4 and the Express edition is already downloadable.  So download that and use SSMS-EE?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.