Microsoft CRM 4 Import - Job progress could not start and still in 'waiting' status

Hello,
I'm trying to Import Data in MS CRM 4, but after submitting the job, but my job's Status Reason in Settings / System is 'Waiting' and the Job progress will not start.

I saw the related post about my problem at http://www.experts-exchange.com/Microsoft/Applications/Microsoft_Dynamics/Q_23904221.html and configure my server as http://support.microsoft.com/kb/950416 , but my problem still exist.

'Microsoft CRM Asynchronous Processing Service' is up and running and there isn't any more information on error log on the Server.

Please help...
LVL 4
mbprogrammerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Feridun KadirPrincipal ConsultantCommented:
check that the asynchronous service is running on the server
0
mbprogrammerAuthor Commented:
thanks for reply,
As my prev post, i say 'Microsoft CRM Asynchronous Processing Service' is up and running...
0
Feridun KadirPrincipal ConsultantCommented:
Oops sorry about that. I just saw the headline on my mobile.

It seems that you checked all the things that I would have mentioned. If you look at the list in Settings | System Jobs do you see other types of jobs stuck at waiting?

0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

mbprogrammerAuthor Commented:
Don't worry about that,
When try to import 1 file, MS CRM generate 3 jobs like attached screenshot.
CRM.png
0
Feridun KadirPrincipal ConsultantCommented:
Let's see if we can get more info about what is happening.

In the System Jobs list, would you please use Advanced Find to create a new view, criteria System Job Type Equals Import File Parse and add the columns Error Code and Message.

The message might just help us work out where to look next.

0
mbprogrammerAuthor Commented:
Ok, i found my Jobs Error code and message:

Error Code:
2,147,204,346-

Error Message:
System.Net.WebException: The request failed with HTTP status 400: Bad Request. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.Crm.SdkTypeProxy.CrmService.Execute(Request Request) at Microsoft.Crm.Asynchronous.SdkTypeProxyCrmServiceWrapper.Execute(Object request) at Microsoft.Crm.Asynchronous.UserSettingsCacheLoader.RetrieveUserSettings(ICrmService crmService, Guid userId) at Microsoft.Crm.Asynchronous.UserSettingsCacheLoader.LoadCacheData(Guid userId, IOrganizationContext context) at Microsoft.Crm.Caching.BasicCrmCache`2.CreateEntry(TKey key, IOrganizationContext context) at Microsoft.Crm.Caching.BasicCrmCache`2.LookupEntry(TKey key, IOrganizationContext context) at Microsoft.Crm.Asynchronous.ImportOperation.GetUserLanguage(AsyncEvent asyncEvent) at Microsoft.Crm.Asynchronous.ImportOperation.InternalExecute(AsyncEvent asyncEvent) at Microsoft.Crm.Asynchronous.AsyncOperationCommand.Execute(AsyncEvent asyncEvent) at Microsoft.Crm.Asynchronous.QueueManager.PoolHandler.ProcessAsyncEvent(AsyncEvent asyncEvent)
0
Feridun KadirPrincipal ConsultantCommented:
:( That error message isn't too helpful.

Would you mind running Advanced Find again please and changing the System Job Type criteria to just Import and posting the error message?

0
mbprogrammerAuthor Commented:
Thank you for helping me, but i got same result


AdvancedFind.png
0
Feridun KadirPrincipal ConsultantCommented:
OK. Here are some questions:

1. Has anyone succesfully imported data into CRM?
2. Have you applied any Update Rollups to the system?
3. What account is the Microsoft CRM Asynchronous Service running as?  (Network Service is recommended)
4. Can you please run the following query on the MSCRM_CONFIG database:

select columnname, nvarcharcolumn from deploymentproperties
where nvarcharcolumn is not null

The entry against AsyncSdkRootDomain should be the base URL for your CRM deployment e,g, http:.//crm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mbprogrammerAuthor Commented:
Hi feridun,

Thank you for helping me; My problem solved by changing AsyncSdkRootDomain from my CRM server's NETBIOS name to FQDN. Because my CRM's website only working with Host Header.
0
mbprogrammerAuthor Commented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Enterprise Software

From novice to tech pro — start learning today.