Out of Office settings cannot be displayed

when using outlook 2007 and the users mailbox is on an Exchange 2010 server
the out of office assistant doesn't work. When you start the out of office
assistant the following message is displayed:

'Your Out of Office settings cannot be displayed, because the server is
currently unavailable. Try again later.'

LVL 1
TchekboAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
0
basbasbasCommented:
You have to start the Autodiscover service, please read:

http://technet.microsoft.com/en-us/library/bb124251.aspx

0
Alan HardistyCo-OwnerCommented:
Out Of Office (OOF) requires the use of the Autodiscover service, which if not setup properly and if you have not setup an A Record in your External DNS records for your domain, will not work.
Make sure you have added an A Record pointing to the IP address of your Exchange 2010 server.  Then if all is well with your server, you OOF will work straight away.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

TchekboAuthor Commented:
http://petenetlive.com/KB/Article/0000197.htm : not work

http://technet.microsoft.com/en-us/library/bb124251.aspx : outlook anywhere already activate

How to add  A Record pointing to the IP address of your Exchange 2010 server ?
0
Alan HardistyCo-OwnerCommented:
Login to your Domain's Control Panel and add an A Record called Autodiscover and ,ake sure you add the IP Address of your Exchange Server as the Detail.
Example:
Name               Type        Detail
Autodiscover      A            123.123.123.123
0
TchekboAuthor Commented:
For use OOF, I am obliged to add a record called autodiscover in my domain's control panel ??? Why? OOF is in Exchange 2007, not in my Domain ??!

I'm sorry, I don't understand....
0
basbasbasCommented:
Outlook searches for 'autodiscover.yourdomain.ext' to be able to use OOF. 'Autodiscover.yourdomain.ext' points to your exchange server, and that is the only correlation between your domain (DNS) and Exchange!
0
TchekboAuthor Commented:
Ok thanks for ressources.

I have created a host server.domain.local in DNS Server and add 123.123.123.123 server.domain.ext in my host file.

When I execute OUtlook 2007, I have a security alert for accept certificate. But OOF don't work.
0
Alan HardistyCo-OwnerCommented:
The DNS record Autodiscover has to be created in your Domain DNS records via the Domain Control Panel - NOT on your own server for your internal records.
Outlook will look up https://autodiscover.yourdomain.com/autodiscover/autodiscover.xml.  This Fully Qualified Domain Name has to resolve properly and unless you host your own DNS internally, the autodiscover record needs to be created in the DNS records for your domain name from the Domain Registrar that you bought the domain name from.
0
TchekboAuthor Commented:
But I use outlook only in internal
0
Alan HardistyCo-OwnerCommented:
You may well do - but Outlook 2007 and above uses Autodiscover to discover the mailboxes on your own server using the external DNS records and it looks there for Autodiscover.  If that is not setup, then you cannot automatically configure your email accounts and Out Of Office will not work.
In Outlook 2003 - this was not a problem.  Outlook 2007 introduces this new 'feature' and I have advised you how to make this work properly.
You have two choices:
  1. Don't setup Autodiscover properly and lose the ability to use Out Of Office and automatic setup of Outlook using just your email address
  2. Set it up and have all the features work properly.
0
basbasbasCommented:
Just for OOF to work you don't need to add the DNS-entry in an external DNS, just add the entry to the DNS on your server. Make sure you point the record to the internal ip-adress of your server (of course 123.123.123.123 is an example).

Read http://www.msexchange.org/tutorials/Uncovering-New-Outlook-2007-Discover-Service.html it will explain how to do things!
0
Pete LongTechnical ConsultantCommented:
Did you add the hotfix above?
0
TchekboAuthor Commented:
Ok I have created a dns-entry in my domain, but the problem is always present.
0
basbasbasCommented:
Are you able to ping 'autodiscover.yourdomain.ext' from a workstation? Is the returned ip-address the internal address of your mailserver?
0
basbasbasCommented:
Another thing; in IIS-manager, in Server->Sites->SBS Web Applications->Autodiscover, change the SSL-settings to ignore client certificaties.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TchekboAuthor Commented:
When I ping autodiscover.yourdomain.ext, I have adress of my mailserver

I have ignore client certificaties in SSL-settings for autodiscover, and the problem persists

I have tested my setting outlook and I have this error : "Autoconfiguration was unable to determine your settings!"
0
TchekboAuthor Commented:
Ok I resolve my problem !

In SSL settings, I have selected "Ignore" for autodiscover in IIS.
0
South ModModeratorCommented:
Tchekbo,

It would appear that your resolution would be almost identical to the suggestion by basbasbas here: http:#a32344762. As such, you should accept that comment as your solution.

If you have a valid reason for your action, please respond here and we will consider it. Otherwise, one of the Moderators will be along in a few days to take action as needed.

SouthMod
Community Support Moderator
http://www.experts-exchange.com/Q_26192191.html
0
Alan HardistyCo-OwnerCommented:
I was waiting for an objection on this one!
I agree that basbasbas's comment should be awarded the points as this seems to be the solution accepted and has been overlooked.
0
TchekboAuthor Commented:
Exactly! thx basbasbas !
0
Alan HardistyCo-OwnerCommented:
Nice one Tchekbo.  Much appreciated by all I suspect.
Alan
0
basbasbasCommented:
Yep, thx! Glad I could help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.