Can't map a folder of my WD MyBookWord HardDisk

I have a VPN connection betweem my office and my home. I connect via this vpn connection. At Home I have an external HD : WD MyBookWorld that i can ping but can't map a folder. The adrress of this HD is 192.168.1.7. The firewall is 192.168.1.1. I tried to map a shared folder of a pc (192.168.1.10) and it works. So I don't know how to access my data on this HD over the VPN connection.
ets_dciAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Darr247Commented:
Are you able to map a shared folder on the MyBook World drive from your home network?
If not, there's either something wrong with the drive or you haven't set it up correctly by logging into http://192.168.1.7 and adding a shared folder on the File Sharing tab.
If I recall correctly, the default name is admin and the default password is 123456.

Once you're able to map a shared folder from the MyBook World on your LAN, then you can access it remotely like any other drive letter on the machine your VPN'ing to...

Did you try the Mionet software that comes with the MyBook World models?
(I think the $8/month charge is a bit much; even the Pro version of http://logmein.com is less than $6/month, and its free version might do everything you need anyway.)
ets_dciAuthor Commented:
Yes I can map a shared folder from my LAN at home by : net use m: \\192.168.1.7\public password /user:username for example. That works fine. The problem is that it doesn't work when I'm outsite. I resume : the VPN connection works, I can ping my WD storage networkdrive but i can't acces any of the shared folder. My configuration is  the following :

Client VPN => Router => Internet => Netgerar CBVG834G (at home) => FVS124G (VPN firewall at home) => WDStorage.

I even try to access a shared folder of another PC. After disabling the Windows XP Firewall I could access to a C$ Share. It means that from client VPN I can access to shared folder at home. It doesn't work for WDStorage.
About mionet yes I can access to WD My Book World. I simply wanted to use VPN to avoid using mionet.

ets_dciAuthor Commented:
I create a test shared folder on WD MyBookWorld and i can give a VPN policy allowing access to my private LAN if someone wants to try or makes test. Just let me know.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

bbaoIT ConsultantCommented:
> I can ping my WD storage networkdrive

from where? the remote VPN client?

anyway, just double check if you have configured the default gateway for the WD box. as per your scenario, it should be pointing to 192.168.1.1, the same for your home PC.
ets_dciAuthor Commented:
Yes I can ping WD Storage from VPN Client outiside home.
When I try to map a shared folder : net use m: \\192.168.1.7\public password /user:username for example I get the message : system error 53 occured. the network path was not found.
bbaoIT ConsultantCommented:
it seems to be an NTLM authentication issue.

i guess your remote VPN client at your office is in an AD domain, right?

please check the following KB, and try to change the value of "LMCompatibilityLevel" to 1 (Send LM authentication and NTLM authentication and use NTLMv2 session security if negotiated).

You may experience authentication issues when you access a network-attached storage device after you upgrade to Windows Server 2008, to Windows Vista, to Windows Server 2003, or to Windows XP
http://support.microsoft.com/kb/954387

hope it helps,
bbao
ets_dciAuthor Commented:
Unfortunately it doesn't help
dethbyltCommented:
When you access the other share on your home network, do you use the same method?  (netuse <IP addy>...).  

Have you tried to access the path via the DNS name for the Worldbook?

I assume that attempts to just browse to or type the path in the run command fail?  Can you try to access \\server\share from the run command and then let it prompt you for a password?
bbaoIT ConsultantCommented:
can you try accessing your home WD box from another place other than your office? this will make sure there is no domain and other authentication method used in the test, say your friend's place. if it is OK from your friend's home, i believe it is still a NTLM related authentication issue.
Darr247Commented:
The MyBook World devices are self contained samba servers, if that helps anyone. I haven't had a chance to try accessing mine from remote since this question was opened.
ets_dciAuthor Commented:
Latest tests :
1. Browse to or type the path in run command failed also
2. Trial of : \\server\share from the run command and then let it prompt you for a password : ended with a message box : path not found. So same result than console window.
3. I don't know how to acces the path via the DSN name !!
4. At Home I use the same method : net use ...
5. Trying to access WD Storage from another place give exactly the same results. => Path not found...

Yesterday I cheked the type of share : it is CIFS.
I also test with a newer WD Storage (That my boss bought yesterday ). The 1 TB version with more shared type : CIFS, NFS, FTP.
My WD Storage is the 500GB version with bue rings.
Big surprise : I can access remotely with VPN client the version 1TB (net use ...) and map a shared folder.
So now I'm sure that every thing by my VPN & Network works fine. May be it's simply a problem with the firmware of the old version (blue rings 500 GB).

Should I buy new WD Storage ??
May be it will be the easiest way to solve this problem. After all, time is also money !
bbaoIT ConsultantCommented:
ets_dciAuthor Commented:
Yes I have the latest firmware.
bbaoIT ConsultantCommented:
tried accessing your home WD box from another place other than your office, or other system (say XP HOME)??
dethbyltCommented:
Please make sure that the computer you are using to access the WD Device is capable of accessing a CIFS share and that the CIFS protocol is not blocked by any of your internet devices.  The fact that the newer device is not using CIFS and the old one is tells me that the protocol is the likely culprit.

Here is a Microsoft document on CIFS: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=C4ADB584-7FF0-4ACF-BD91-5F7708ADB23C.
ets_dciAuthor Commented:
First of all how to know if my PC is CIFS capable. I have an XP Pro.
Second the test that I made with the new WD Storage was based on shared folder (say test) using CIFS share only. The test was made with the same PC !!

Any way I've just got an answer of WD support confirming me that the WD Storage with blue rings are only accessible with the mionet software. What a shame !
bbaoIT ConsultantCommented:
> the WD Storage with blue rings are only accessible with the mionet software.

the reason?
Darr247Commented:
Mine is a 1TB with the blue rings (fw 2.00.19), and I do not use the mionet-based software (WD Anywhere Access is the 'branded' name WD chose for it).

I left the default 'PUBLIC' folder open (r/w) to everyone and made a different folder for storage and to use for clonezilla images across the network. In my DHCP server I reserved its IP address by MAC address. My windows machines map it to the same drive letter at reboot; my linux boxes mount it CIFS in /media/MBW1 at boot (from /etc/fstab). I did try it NFS and it would mount, but there were less permission, owner and SELinux context issues mounting it CIFS.

Anyway... I will attempt to access it from remote this afternoon using the LogMeIn free version.
ets_dciAuthor Commented:
1.
I don't know why blue rings are only accessible with the mionet software. But that was the answer given to me by WD support this afternoon. May be they told me that to simply close the case !!

2. for Darr247
Mine is 500 GB (fw 2.00.19). I noticed that you talk about NFS. I can't see any another share type than CIFS in my WD MyBookWorld. ! Is there any difference between 500 GB & 1 TB versions !
Darr247Commented:
I don't see any file system types mentioned anywhere on the drive...  where are you seeing that?

I am able to access it using the free logmein.com account, by accessing the (windows) computer with the logmein software installed, and which has the MyBook World drive mapped to a drive letter.

I could even access the logmein setups from remote, added a file share on the MyBook World, copied its link to clipboard, transferred the clipboard to my remote laptop, then pasted it into the laptop's browser to download it, Kind of a kludge, but it's definitely accessible from remote without the mionet software.

What VPN are you using?  I installed OpenVPN on one of my fedora boxes before I left but did not have time to finish setting it up...
ets_dciAuthor Commented:
You can see the share type when you create a folder.

What I want to is to access the WD Storage directly not via a PC.

I'm using the Netgear Prosafe software.
Darr247Commented:
Samba servers use the SMB protocol, which is essentially NetBIOS over TCP/IP.

In your router, try forwarding ports 137 UDP and 138 UDP, 139 TCP, and 445 TCP+UDP to 192.168.1.7, then try the net use mapping from remote.

137 is NetBIOS Name Service
138 is NetBIOS Datagram Service
139 is NetBIOS Session Service
445 is Microsoft Directory Services
Darr247Commented:
> What I want to is to access the WD Storage directly not via a PC.

Wait - I thought you were using a VPN...  why do you need a VPN if you're not talking to a PC on your LAN?
ets_dciAuthor Commented:
Already tried without success
ets_dciAuthor Commented:
I use VPN to access to my WD Storage. My VPN server at home is netgear FVS124G. I don't need to access to pc or via a pc. I need only access to my data stored on WD Storage wich is accessible on the net.

Any way I 'll buy the new MyBookWorld one wich offers more possibilies : FTP, NFS, etc...

Thank for all of you for you help.
Darr247Commented:
From both work and from home, surf to http://grc.com and choose Services->ShieldsUp! from the menu at the top, click the Proceed button, put "137-139, 445" (sans quotes) in the field and click the 'User Specified Custom Port Probe' button. That should tell you if either provider is blocking those ports. They should be all red; if any come back green it means those ports are being blocked somewhere.
ets_dciAuthor Commented:
From both work and home I know that ports are not blocked since I can access the new WD Storage with the command net use ... wich uses these ports. So I don't think it's a problem of ports. After all The WD support tell that the external harddisk with bluerings is not accessible without mionet !
Darr247Commented:
> After all The WD support tell that the external harddisk
> with bluerings is not accessible without mionet !

Well, what they are telling you is simply untrue, then... I demonstrated on the 4th that I can access mine (same firmware version - 2.00.19) without mionet, no problem.

Does your netgear appliance have a static IP or are you using a dynamic DNS service like DynDNS.com?
ets_dciAuthor Commented:
static IP

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.