Exchange Autodiscover

Have just moved 10 test mailboxes from Ex2003 to Ex2010. As a test before the move I logged into Outlook 2007 on 5 of the users, the others had never been logged in before.

I have turned off the Ex2003 server. The 5 users who hadn't ever logged on before work fine when opening Outlook, but the 5 other users outlook are still looking for the Ex2003 server.

I thought Autodiscover would fix this so I have set up DNS entry for 'autodiscover' and ran the command:
> Set-OutlookProvider –id exch –server:ex2010

but the XP client is still looking for Ex2003.
Tried to "Test Email AutoConfiguration" in outlook but it seems you need to login to start the test...which I cant do!

(I know that leaving the Ex2003 server on will make outlook change its settings but I want autodiscover to do this and turn off Ex2003)
LVL 1
PeteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkhaterCommented:
users with an outlook profile should be able to communicate with their old exchange server to know their mailbox was moved.
0
PeteAuthor Commented:
I thought autodiscover fixed this though.
If I manually 'Repair' the profile it works fine and I thought this repair uses the autodiscover service?
0
AkhaterCommented:
if you manually "repair" the profile it will work, it will also work if you just open outlook

outlook will connect to the old server and know its mailbox was moved to the new one and the profile will be automatically "repaired'
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

PeteAuthor Commented:
thanks, but the question is about autodiscover. I thought autodiscover was deigned for situations just like this?
From initial Question:
(I know that leaving the Ex2003 server on will make outlook change its settings but I want autodiscover to do this and turn off Ex2003)
0
B HCommented:
did you only create an "A" record for autodiscover, or did you set up an SRV record?  an SRV record for _autodiscover is what it looks for

i've had way more problems with autodiscover than not...  it never seems to work right when you're outside of the network.  even if you dont want to use it, outlook 2007 looks for it every single time you open outlook.  this causes all kinds of security mismatch errors when you're trying to log on to "mail.domain.com" but outlook sees "autodiscover.domain.com" with the certificate for mail-dot.

in any case, at a minimum you'll need a public and a private SRV record... private in the local dns to point to the internal ip, and public on your dns host to point to the external ip....
0
PeteAuthor Commented:
Thanks, I'll try the DNS record first. Can you please tell me how to setup a SRV record (rather than A record).
 
2008 server
0
B HCommented:
in your local dns server, in the forward lookup zone for your domain,
new > other record > SRV
_autodiscover, _tcp, port 443, host mail.domain.com (whatever yours is)

that tells the autodiscover feature "for the server offering this service, go to tcp port 443 at this host)
adjust 443 for whatever you're using if not the default

in your external dns, it depends on your host and how their dns manager function works

official how-to:
http://support.microsoft.com/kb/940881
0
PeteAuthor Commented:
have done this but seems to make no difference. can you please look at attached screenshot of autoconfiguration test from working outlook profile (after repair). ex10 is my new server which all looks correct, so why are my other users (who have previously logged into the ex2003 server) still hanging, looking for ex2003? rather than failing and using the autoconfiguration (autodiscover?) settings?
 
thanks
 

autodiscover.doc
0
AkhaterCommented:
users connected to your domain doesn't use autodiscover dns entry they use the SCP entry.

in the same place where you plased the screen shot move to xml and give me the results
0
PeteAuthor Commented:
getting really confused, should I change the Ip address of the 2010 server to that of the 2003 server? took ages to get any account to work.
here's SCP XML output
Thanks
 
 

xml-output.txt
0
AkhaterCommented:
no you should NOT change the IP, can I just understand why you do not want to follow the  "standard procedure" to keep the exchange 2003 on ?
0
PeteAuthor Commented:
we are a school with potentially 100's of users per machine and therefore (sometimes) 100's of outlook profiles per machine. even if i left the ex2003 server turned on for a month I would be getting 'outlook profile error' support calls in 3, 4, 5 months time.
0
AkhaterCommented:
OK I understand better your concern now

I assume you have tried to restart outlook on one of the clients, for how long have you waited?

in pure theory outlook should query autodiscovery service every time it is on

what are the results of get-clientaccessserver |fl *aut* and of  get-mailboxdatabase | fl name,*rpc*
0
PeteAuthor Commented:
I will take a look (maybe tomorrow now) did you conclude anything from the XML screenshot in previous post?
0
AkhaterCommented:
the XML file you attached proves that autodiscover service is working correctly so is the fact that new profiles are directly configured right.


we are talking about computers joined to your AD domain right ?
0
SaakarSenior Technical ConsultantCommented:
1. Open Exchange 2007 Shell

[PS] C:\Documents and Settings\jchong\Desktop>Set-Mailbox marpoo -ApplyMandatoryProperties

1. Move the mailbox to a different store on Exchange 2007

2. Verify that inheritance is checked for the user in the security tab, advanced in Active Directory Users and Computers.
I ma suggesting this by looking @
<LegacyDN>/o=Pete Organization/ou=First Administrative Group/cn=Recipients/cn=marpoo</LegacyDN>
If the mailbox is moved already it should be pointing to Exchange 2010 and not Exchange 2003
 
Hope this helps!!
0
PeteAuthor Commented:
thanks saakar_rao, can you please explain what I am actually doing by running the command and moving the mailbox to another store?
the mailbox is in the 'staff' store on exchange 2010, should I create another store called 'staff2' and move it there then?
0
Narayan_singhCommented:
Inorder for outlook to automatically go to exchange 2010 you must have exchange 2003 up, user should loginto the outlook atleast for once with exch 2003 up after moving his mailbox to exch 2010.

However if you create a new profile autodiscover should automatically pick up the right server but for the profile which is already configure with old exchange, it needs to work above mentioned way.

Event though you move the user to Exchange 2010 , the legacyExchangeDn would still point to old Admin group as it doing in your case

<LegacyDN>/o=Pete Organization/ou=First Administrative Group/cn=Recipients/cn=marpoo</LegacyDN> so that should nt be the problem.(how ever you can change it so that it points to the new admin group refer http://technet.microsoft.com/en-us/library/bb288905(EXCHG.80).aspx step 5

<Server>EX10.X.LOCAL</Server>
        <ServerDN>/o=Pete Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EX10</ServerDN>
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Narayan_singhCommented:
Just ignore :
"<Server>EX10.X.LOCAL</Server>
        <ServerDN>/o=Pete Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EX10</ServerDN>"
0
PeteAuthor Commented:
OK great, can you please clarify the command? Can I do this for all users at once?
 
 
0
Narayan_singhCommented:
For doing it in bulk
Get-MailboxDatabase -Identity Server01\StorageGroup01\MailboxDatabase01 | Set-Mailbox -ApplyMandatoryProperties ( i think it shoud do it in a bulk for perticular database, you can try it, however i dont think there is a need to run this command, this is not due to mendatory properties not applied.)

For outlok to pint to new server you keep the new server up and login in outlook or use some script to redirect the outlook to new server, see this thread:
http://social.technet.microsoft.com/Forums/en/exchangesvrmigration/thread/d042cab9-2309-425b-9e72-6970d028ffa3
0
PeteAuthor Commented:
Thanks, I am thinking of trying the exprofre.exe tool, with /s switch -
"Updates profiles based on a change in server name rather than a change in the legacyExchangeDN attribute."
Narayan_singh: you say the problem is not based on  legacyExchangeDNso the change for 'server name' may work?
0
Narayan_singhCommented:
This problem is not due to legacyExchangeDN changing server name manually or using the tool will work.

However you can change the legacyExchangeDN using Admodify tool,steps are given in http://technet.microsoft.com/en-us/library/bb288905(EXCHG.80).aspx step 5
0
PeteAuthor Commented:
sorry I don't understand your post.
"This problem is not due to legacyExchangeDN changing server name manually or using the tool will work."
do you mean NOT worK?
if so why then do you point me toward admodify that makes that change...?
0
Narayan_singhCommented:
You should change legacyExchangeDN to avoid any issues with Free busy.this is just FYI, not related to your current issue.

And as your issue is changing the exchange server name to new server, that can be done by using exprofre.exe toolor manually.

legacyExchangeDN is not related to the current issue.it was just a information i wanted to give you.
0
PeteAuthor Commented:
thanks I will set the ApplyMandatoryProperties tomorrow.
i will also test the exprofre tool as well although there is reports on the net of it not working for exchange 2007 onwards.
just as a final note if i leave exchange 2003 on for a bit after the migration what is the minimum state it can be left in. if i move all mailboxes, public folders, policies and connectors will it still be an 'exchange server' able to redirect outlook?
0
SaakarSenior Technical ConsultantCommented:
Was busy with some other assignments..
Check this link for more info
http://blogs.technet.com/evand/archive/2007/02/28/applymandatoryproperties.aspx
Extract from the above link...
What actually happens when you "apply the mandatory properties"?

Applying the mandatory properties to a mailbox means that we run through the following algorithm:
1) Check whether the mailbox is hosted on E2k7 server by verifying its ServerLegacyDN (by the prefix “/o=<OrganizationName>/ou=<E2k7DefaultAdministrativeGroupName>/”)
2) If it is, we do both of the following things:
a. The ExchangeVersion is changed to Exchange 2007 ExchangeVersion value: "0.1 (8.0.535.0)"
b. The RecipientTypeDetails/RecipientDisplayType is updated according the value of “IsResource/IsLinked/IsShared”
3) Otherwise, we error out to tell that the task cannot do it because it is hosted on legacy server
The end result is that the mailbox will have its ExchangeVersion, RecipientTypeDetails, and RecipientDisplayType updated to match reality
0
Narayan_singhCommented:
Whats update ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.