Perl Config::Inifiles error

Simple code but can't open the .ini file I want to read:
---------------------------------------------------------------------
use Config::IniFiles;

my $ini = Config::IniFiles->new(-file => 'test.ini');
---------------------------------------------------------------------
error is:
Failed to open test.ini:  No such file or directory at line 3

Even when I give the full path to the file I get the same error.

Can someone tell me what I am doing wrong?
kkbenjAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kim RyanIT ConsultantCommented:
Maybe check of the file has read permission. Also do you use forward slashes in the path name?
0
kkbenjAuthor Commented:
This is Windows.  When I look at the file type, it is listed as a shortcut.

I have tried \\ on the path as well.
0
mankowitzCommented:
Windows shortcuts aren't really dynamic links, like they are in unix. You can either point to the actual file location, or use something like this http://www.perlmonks.org/?node_id=263858
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kkbenjAuthor Commented:
Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Perl

From novice to tech pro — start learning today.