Exchange 2007: Unable to relay 'log'

Hi,

Does exchange 2007 has a log where i can find the relay errors?

I have created a 'relay access' receive connector for an external server which is connected with a business 2 business vpn connection to our lan but the external server gets the 'unable to relay' error message when sending messages...
I've added a test server from our lan to the remote access list to test the relay access ant it works, but no success with the external server.

I'm not sure that the correct IP is added to the remote servers list.
So, does exchange has a log where i can find the relay erros, source ip's,..

Thx
KozznAsked:
Who is Participating?
 
Shreedhar EtteConnect With a Mentor Commented:
Hi,

Refer this article to configure relay:
https://exchangepedia.com/blog/2007/01/exchange-server-2007-how-to-allow.html

Hope this helps,
Shree
0
 
Mahmoud SabryCommented:
find the below article by Akhater from Exchange experts

First of all you should know that a mail server should be configure to unconditionally (not talking about spam/viruses here) accept emails sent to users in the SMTP domains it is serving. However, to avoid spamming others and being blacklisted, it should be very careful about who gets to send emails to other SMTP domains using its services, and that's what is called relaying.

This should explain why, in the above scenario, emails sent to internal users are received but not to external one, that is because Exchange is refusing to relay. To solve your problem and enable your application/web server to be able to send external emails, you should allow it (or its IP address) to relay emails through your Exchange server and here is how to do it in Microsoft Exchange 2007 and Microsoft Exchange 2010.

   1. Add another internal IP to your exchange server, say 1.1.1.1
   2. Create a new receive connector, configure it to listen only to the newly added IP address & accept SMTP connections only to the application\web server IP address. This can be done by GUI using Exchange Management Console or through Exchange Management Shell by running

      New-ReceiveConnector -Name AllowRelay -usage Custom -Bindings '1.1.1.1:25' -fqdn server.domain.com -RemoteIPRanges WebServerIpAddress -server MYEXCHANGESERVER -permissiongroups AnonymousUsers

   3. Now that the connector is created, you should allow relaying on that connector, this can only by achieved using Management Shell as shown below.

      Get-ReceiveConnector AllowRelay | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

   4. Finally configure your web server or Application to use the Exchange server's newly assigned IP 1.1.1.1 as SMTP server.

N.B.:Make sure to change the 1.1.1.1 by the additional IP you added to your Exchange server, WebServerIpAddress with the IP of your Webserver/application, MYEXCHANGESERVER by the name of your exchange 2007/2010 and server.domain.com by the FQDN of your exchange server.
0
 
Mahmoud SabryConnect With a Mentor Commented:
to see the log for this, enable logging for the relay receive connector
 to do so, right click the rely connector, properties, in the protocol logging level, select verbose

look to the log in the logging path, by default C:\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLog\SmtpReceive in the HUB transport server

look in to the log and verify that the ip of the remote SMTP is the IP address of your server
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
KozznAuthor Commented:
Thx all for the info,

i  have an edge transport server in the dmz, do i have to create the new receive connector also on the edge? or only on the exchange server?
0
 
Mahmoud SabryConnect With a Mentor Commented:
make it in the HUB and it will replicate directly to Edge serevr

to force the replication
from HUB, using EMS
Start-EdgeSynchronization
0
 
KozznAuthor Commented:
I had created the receive connector on the edge.
I removed it now on the edge, did a force repliciation command with the 'Start-EdgeSynchronization' on the hub but it won't appear in the receive connector on the edge...
0
 
Mahmoud SabryConnect With a Mentor Commented:
did u created the new relay connector on the HUB?

it must be created first on the hub , then it will be replicated to the edge
0
 
KozznAuthor Commented:
I have created it first on the hub(exchange server), than i did a ''Start-EdgeSynchronization'  but it didn't appear on the edge.

On the hub, i added a second IP on the nic and assigned only that IP to the 'use these local ip-addresses to receive mail...' network tab in the receive connector i created before.
Is this the right way to configure it?
What IP address do i have to configure on the edge in the 'use these local ip-addresses to receive mail...' network tab in the receive connector?

Should I open port 25 to the second IP of the hub in our firewall?
0
 
KozznAuthor Commented:
It works, thx!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.