Exchange 2010 - IMAP - SMTP traffic from users

Hello,

I've configured IMAP4 on my Exchange 2010 server. (Also enabled the service with auto start)
Made a new receive connector (internet) who allows anonymous traffic from all networks.
Deleted the all networks in the default receive connector and added my local network xxx.xxx.xxx.xxx/24 in it.

Now my clients can connect through IMAP4 using outlook (I know mapi is better but outlook doesn't support 2 mapi boxes). In outlook the send settings for this account are the same as "the receive options" but with port 25 instead off 143. The test works fine, but when sending an email, nothing happens.
On the exchange side there is also nothing incoming.

Tried playing with outgoing authentication, changed the port to 587 with TLS authentication, nothing does work.

Can anyone tell me what I'm forgetting?

Thanks for the reply's
NR_EISAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BikkelbinkCommented:
Hi NR EIS,

Can you confirm that the server is listening on the port specified on your receive connector?
Netstat -an | find *:587
Can you telnet from a IMAP4 client to the specified port on the server? If you can, try to send mail with the SMTP commands and see what error comes up.
When you can connect, set the protocol logging level on the Rec. connector.

Regards,
BB
0
Bruno PACIIT ConsultantCommented:
Hi,

What do you exactly means saying "nothing happens" ? Does the message stay in outbox folder ? Does it disappear  but is never received ?

Did you try to enable SMTP logs on Exchange 2010 to verify if the SMTP session dialog is ok ?


Another thing... Outlook permits you to open has many MAPI mailboxes as you wan't (well... at least 3 I'm sure) simultaneously in Outlook... You just have to give permissions of the secondary mailboxes to be able to open it in Outlook as a secondary mailbox. So what do you exactly mean saying "outlook doesn't support 2 mapi boxes" ??

Have a goo day.
0
NR_EISAuthor Commented:
@ BB: A telnet session on 587 & 25 works.
I can helo my server and I get a "sender ok" to the command mail from:xxx@xxx.xxx (the rest of the command I don't know out of my head anymore).

@ PaciB: with nothing happens, I mean that the bar right under outlook says sending 1 of 1 and then disapears like sending a normal mail. Afterwarts I do get an unread message in my Inbox (only in the tree, in the inbox everything stays read).

and I don't  think that mapi works from 2 different domains? The add a mailboxes is handy when adding one from in your main domain.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

NR_EISAuthor Commented:
To provide some more information: my receive connectors are configured as followed:
- Client
FQDN: servername.domainname.local
Network: all IP's on port 587, receive from 0.0.0.0-255.255.255.255
Authentication: TLS
Permission: exchange users
- Default
FQDN: servername.domainname.local
network: all IP's on port 25, receive from lanip0/24
Authentication: TLS, basic after TLS, Exchange, Integrated
Permission: Exchange users & servers, legacy exchange servers
- Internet (self made)
FQDN: server.domainname.com (this is existing subdomein)
Network: all IP's on port 25, receive 00.0.0.0-255.255.255.255
Authentication: TLS
Permission: Anonymous users

And then the Outlook settings:
- Incoming: server.domainname.com (same as internet fqdn)
- Outgoing: server.domainname.com (same as internet fqdn)
- Username: domain\username
- IMAP port: 143, none encryption
- SMTP port: 25, none encryption
0
NR_EISAuthor Commented:
I've set the Client connector to allow basic authentication without TLS, and then the mail sending works.
When enabling TLS and activating this in the mail client it doesn't work.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BikkelbinkCommented:
If you configured Outlook to use TLS, and it still does not work, check if you configured a valid certificate on your connector. (Trusted, Name, valid)
It has to be something with your cert...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.