full text cluster resource failing

Hi there, we're got a sql 2000 cluster and the full-text resource has failed on both sides of the cluster (active-active).  The event log shows -

"The Gatherer property mapping file cannot be opened. Error: 80070002": and "An error occurred during the online operation for instance <SQL Server Fulltext>: 80070002 - The system cannot find the file specified."

All I've been able to find googling involves re-installing, or removing the search service, which we tried on a sandbox install and it got totally messed up.  

Just wondering if anyone has recovered from this error without a reinstall. It's an old system that uses this instance, with a 600 gig db, so we REALLY want to avoid a reinstall if possible.

Thanks for any thoughts!
rfamilypaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

James MurrellProduct SpecialistCommented:
have you looked at this http://support.microsoft.com/kb/304282
0
rfamilypaAuthor Commented:
Yes :(  That one says we have to reinstall the instance, so I'm looking for any kind of workaround that may have been used.
0
rfamilypaAuthor Commented:
We solved this problem by following the steps in this link: http://www.tech-archive.net/Archive/SQL-Server/microsoft.public.sqlserver.clustering/2006-08/msg00222.html

We did not have to reinstall the SQL instance!!

Basically, we had to delete the cluster resource, delete a registry key under Search\Install, run the searchstp.exe, run the ftsetup.exe (0 1 0 1 0 as the parameters), add the resource back, add 2 new registry keys in the Cluster\Resource registry for ApplicationPath and ApplicationName, then we were able to bring the new Full-Text resource back online.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rfamilypaAuthor Commented:
I meant without having to reinstall, not reboot.  Long night :)
0
James MurrellProduct SpecialistCommented:
great news
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.