automatic redirect of OWA page from http to https not working on IIS 7 and Exchange 2010...

willlandymore
willlandymore used Ask the Experts™
on
Hi,

I'm trying to enable automatic redirect of requests going to http://server.domain.com/owa to https://server.domain.com/owa but so far it's just giving me the typical 403 error when I try to access the site on http.

I've got the certificate working and everything is working great using the https URL. I have also have gone into IIS 7 and enabled http redirect on the default website to go to https://server.domain.com/owa and then checked the box for 'only redirect requests for content in this directory' and have the 302 setting. Then I've applied the settings and restarted IIS.

How can I get the automatic redirect so that if someone browses to http://... they get sent to https://server.domain.com/owa?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Technical Manager
Top Expert 2010
Commented:

Author

Commented:
nope. Still no joy.

Went through the first article step by step and have all the same settings. Also gave the whole box a reboot but I still get the 403 when I go there.

Author

Commented:
forget it. My mistake.... :)

I was putting the owa on the end of the http request and of coarse the require SSL was on that directory so it was shooting it down like it should have been.

It works if you just use http://server.domain.com with nothing else...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial