ASP.Net And IIS 7 Upload Files

Hi

I have writen a page in ASP to upload files.  This works file localy, but when i move the site to a server running IIS 7 the upload fails saying access is denied.

I know this is a permissions issue, but what NTFS permissions do I need to create on the folder?  I know my AD user hass access, but it still does not work.

Can any one help?

Thanks Brasso



LVL 1
brasso_42Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
try allow Read/Write/Modify permission on your folder to user: IUSR_<machinename>

check this out:

http://www.livio.net/main/writepermissions.asp
0
masterpassCommented:
site to a server running IIS 7 the upload fails saying access is denied.>>>>>>>>>>


Give the permissions to NETWORK ans NETWORK SERVICE accounts
0
sethisaurabhCommented:
Give the Network Service (Read+Write+Execute) permission to resolve the issue.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

brasso_42Author Commented:
Hi

I have added all of the above and still get the same.  With the IUSR_<machinename> what machinename should this be? The client or the server where IIS is installed?

The error I'm still getting is:
Error: Access to the path '\\192.168.1.1\ArticleFiles\Testfile.pdf' is denied

I am sure the path is fine as I can type it in to exporer and brows to that location.

Thanks

Brasso
0
masterpassCommented:
Can you try to add impersonation="true" in the web.config and try ?
<system.web>
<identity impersonate="true" />
</system.web>

Open in new window

0
brasso_42Author Commented:
Hi

I now get the following error and the site will not load.

HTTP Error 500.24 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

Not got a clue what that means :S

Thanks

Brasso
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP

From novice to tech pro — start learning today.