Cannot relay From SMTP Server Application through Exchange 2007

We have a CRM application that send notice to customers. We recenlty installed exchange 2007 and now the relaying does not work. I created a send connector to allow relaying for this server but still the e-mails are being returned with the following NDR:

Delivery has failed to these recipients or distribution lists:

nsarault_33@sympatico.ca
Your message wasn't delivered because of security policies. Microsoft Exchange will not try to redeliver this message for you. Please provide the following diagnostic text to your system administrator.







Diagnostic information for administrators:

Generating server: POLARIS.SDGLibrary.local

nsarault_33@sympatico.ca
#< #5.7.1 smtp;550 5.7.1 Unable to relay> #SMTP#

Original message headers:

Received: from POLARIS ([10.1.2.7]) by POLARIS.SDGLibrary.local with Microsoft
 SMTPSVC(7.0.6001.18440);       Sun, 25 Apr 2010 06:00:33 -0500
MIME-Version: 1.0
From: <info@sdglibrary.ca>
To: <nsarault_33@sympatico.ca>
Reply-To: <info@sdglibrary.ca>
Date: Sun, 25 Apr 2010 06:00:33 -0500
Subject: =?utf-8?B?QSByZW1pbmRlciBmcm9tIHlvdXIgbGlicmFyeQ==?=
Content-Type: text/html; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
Return-Path: info@sdglibrary.ca
Message-ID: <POLARISjr8cU6xfPTei000000ab@POLARIS.SDGLibrary.local>
X-OriginalArrivalTime: 25 Apr 2010 11:00:33.0913 (UTC) FILETIME=[872CAE90:01CAE466]

Serge MartinIT TechnicianAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

shauncroucherCommented:
This is the article you need to follow:

http://msexchangeteam.com/archive/2006/12/28/432013.aspx

shaun

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shauncroucherCommented:
Basically, create a receive connector, externally sercured just for your application server and all will be well again.

Shaun
Pro4iaCommented:
Please double check your connector settings -

http://msexchangeteam.com/archive/2006/12/28/432013.aspx
Serge MartinIT TechnicianAuthor Commented:
Okay I used

http://msexchangeteam.com/archive/2006/12/28/432013.aspx

So I guess I will have to go over this again tomorrow to see what I have done wrong. Will post back when done.
Mahmoud SabrySenior IT Systems EngineerCommented:
find the below article by Akhater from Exchange experts, it takes you step by step creating new  relay allowing receive connector

First of all you should know that a mail server should be configure to unconditionally (not talking about spam/viruses here) accept emails sent to users in the SMTP domains it is serving. However, to avoid spamming others and being blacklisted, it should be very careful about who gets to send emails to other SMTP domains using its services, and that's what is called relaying.

This should explain why, in the above scenario, emails sent to internal users are received but not to external one, that is because Exchange is refusing to relay. To solve your problem and enable your application/web server to be able to send external emails, you should allow it (or its IP address) to relay emails through your Exchange server and here is how to do it in Microsoft Exchange 2007 and Microsoft Exchange 2010.

   1. Add another internal IP to your exchange server, say 1.1.1.1
   2. Create a new receive connector, configure it to listen only to the newly added IP address & accept SMTP connections only to the application\web server IP address. This can be done by GUI using Exchange Management Console or through Exchange Management Shell by running

      New-ReceiveConnector -Name AllowRelay -usage Custom -Bindings '1.1.1.1:25' -fqdn server.domain.com -RemoteIPRanges WebServerIpAddress -server MYEXCHANGESERVER -permissiongroups AnonymousUsers

   3. Now that the connector is created, you should allow relaying on that connector, this can only by achieved using Management Shell as shown below.

      Get-ReceiveConnector AllowRelay | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

   4. Finally configure your web server or Application to use the Exchange server's newly assigned IP 1.1.1.1 as SMTP server.

N.B.:Make sure to change the 1.1.1.1 by the additional IP you added to your Exchange server, WebServerIpAddress with the IP of your Webserver/application, MYEXCHANGESERVER by the name of your exchange 2007/2010 and server.domain.com by the FQDN of your exchange server.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.