adprep32.exe /domainprep /gprep /rodcprep do nothing, ... empty log

Hi everyone, am having a problem trying to migrate 2003 server standard 32bit to a 2008 standard r2 server 64 bit

There is an apercu of what I have done and what problem I have faced up…


I executed the adrep32.exe /forestprep
The execution was waiting something… but if I tried to do an ‘Enter’
These commands was returned me nothing

The adprep.log was empty

Searched on the net for a solution…
Executed the command against … adrep32.exe /forestprep
But I tried typing ‘C’ plus an ‘Enter’
And the command succeed as well  

Typing ‘c’ after the command, seam to do like continue for the adprep32.exe /forestprep command. But there no message and no doc about that
Anyway it worked so...


For bean sure checked the log,
Also does a DCDIAG /V /C /D /E /s:yourdcname > c:\dcdiag.log
And a repadmin
So at this point everything was worked fine.

So I passed to the next step

Adprep32.exe /domainprep
Or
Adprep32.exe /domainprep /gprep
Or
Adprep32.exe /rodcprep
Or
Adprep32e.exe /domainprep /rodcprep
Whatever…
 
Those commands returned me nothing… against…. but this time it was no time for typing ‘c’, the command just end directly, waiting nothing….

It was going directly doing to the prompt…
D:\support\adprep>adprep32.exe /domainprep

D:\support\adprep>


It mean against no log…



Tried Executed dcpromo on my server 2008, I was told to execute adprep…

For your advice
All updated are done in my 2003 and 2008 server…

alainboisvertAsked:
Who is Participating?
 
alainboisvertAuthor Commented:
There is a problem with the application adprep32.exe that is on the fallowing DVD version…

Microsoft
Partner network
(oem)

Windows Server 2008 R2 Enterprise (64 bit)
And Windows web Server 2008 R2



Also tested this version on few migrations and the same problem happened all the time when I tried to use this DVD.

If I try the adprep32.exe that is on an other version of windows dvd, it worked….

0
 
Mike KlineCommented:
Can you download adfind  http://www.joeware.net/freetools/tools/adfind/index.htm

run

adfind -sc schver

Do that in the child domain

47 = 2008 R2

44 = 2008

31 = W2K3 R2

30 = W2K3

...just want to see what version you are at

Did you run the forestprep on your schema master and the domain prep on your infrastructure master?

Thanks

Mike
0
 
alainboisvertAuthor Commented:
Well don’t things I have a child domain…
There the situation…

One domain, one forest… the first domain where I have done the dcpromo, is the 2003 server, so the 2003 have all roles, schema master and infrastructure master

 Concerning the 2008 server I just added it to the domain…


But I executed your program on both servers…. There is the result:

For the 2003 server:
Using server: 2003srvtest.2003srvtest.com:389
Directory: Windows Server 2003
Base DN: CN=Schema,CN=Configuration,DC=2003srvtest,DC=com

dn:CN=Schema,CN=Configuration,DC=2003srvtest,DC=com
>objectVersion: 47 [Windows Server 2008 R2]

1 Objects returned

For the 2008 server:
C:\Users\ntadmin\Desktop\AdFind>adfind -sc schver

AdFind V01.41.00cpp Joe Richards (joe@joeware.net) February 2010

Using server: 2003srvtest.2003srvtest.com:389
Directory: Windows Server 2003
Base DN: CN=Schema,CN=Configuration,DC=2003srvtest,DC=com

dn:CN=Schema,CN=Configuration,DC=2003srvtest,DC=com
>objectVersion: 47 [Windows Server 2008 R2]

1 Objects returned

For your advice I done a mistake it not a 2008 standard r2 x64 but a 2008 datacenter r2 x64… but anyway there no difference…

0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Mike KlineCommented:
So it looks like you are at 2008 R2 for your schema,  is it not letting you add a 2008 R2 box?

Thanks

Mike
0
 
alainboisvertAuthor Commented:
Adprep32.exe /domainprep didnt worked, directly do to the prump, log file is empty
0
 
alainboisvertAuthor Commented:
Anyway not sure of what you mean, but I have process with few more test.
  In AD I moved the 2008 serv with my 2003 in the same UO (domain controller)
And for your advice my domain mode is windows 2003 … is the higher level…

Tried against adprep32 /forestprep, ok but still no result for adprep32 /domainprep
0
 
Mike KlineCommented:
What I meant is that your schema is at the 2008 R2 level,  so when you try to promote a 2008 box it still gives you an error?

Thanks

Mike
0
 
alainboisvertAuthor Commented:
Am sorry I don’t fully understand what you mean when you told me to promote a 2008 box:/

Explain it to me if it not what you asked me to try…

There is what I understand of it… executing dcpromo on the 2008 server….
If you mean that I tried it, but I receive a message that asked me to run adprep /forestprep first
0
 
PRAACommented:
Try adprep32 /forestprep enter then press C and enter.
Is like you dont have the advise asking you to have at least W2k SP1.
0
 
PRAACommented:
Verify the adprep folder. It could be you have a different language installation disk.
Copy the adprep folder on the PDC adn renave the language folder to en-us. mine was fr-fr.
 
It work
0
 
INTELLI-NETCommented:
FYI - I was having the same problem with adprep32 not producing any output, even when using "adprep32 /?". My problem was that I didn't copy the en-us folder under the adprep folder from the W2K8 R2 DVD. Once I copied the folder and the files in it, the command ran fine.

The file structure on should be:
 Directory of x:\support\adprep

07/14/2009  05:33 AM         1,508,276 134428a8-0043-48a6-bcda-63310d9ec4dd.dcpromo.csv
07/14/2009  05:33 AM         1,548,004 4444c516-f43a-4c12-9c4b-b5c064941d61.dcpromo.csv
07/14/2009  05:33 AM           661,504 adprep.exe
07/14/2009  05:33 AM           458,752 adprep32.exe
07/14/2009  05:33 AM         1,508,576 dca8f425-baae-47cd-b424-e3f6c76ed08b.dcpromo.csv
07/14/2009  05:33 AM         1,508,734 dcpromo.csv
06/17/2010  04:41 PM    <DIR>          en-us
07/14/2009  05:33 AM         1,850,684 ffa5ee3c-1405-476d-b344-7ad37d69cc25.dcpromo.csv
07/14/2009  05:33 AM             2,356 pas.ldf
07/14/2009  05:33 AM            52,190 sch14.ldf
07/14/2009  05:33 AM            27,939 sch15.ldf
07/14/2009  05:33 AM            10,072 sch16.ldf
07/14/2009  05:33 AM             5,715 sch17.ldf
07/14/2009  05:33 AM            15,789 sch18.ldf
07/14/2009  05:33 AM             4,744 sch19.ldf
07/14/2009  05:33 AM             5,658 sch20.ldf
07/14/2009  05:33 AM             3,650 sch21.ldf
07/14/2009  05:33 AM             7,776 sch22.ldf
07/14/2009  05:33 AM             1,884 sch23.ldf
07/14/2009  05:33 AM             3,456 sch24.ldf
07/14/2009  05:33 AM            26,842 sch25.ldf
07/14/2009  05:33 AM             7,701 sch26.ldf
07/14/2009  05:33 AM            28,186 sch27.ldf
07/14/2009  05:33 AM             1,711 sch28.ldf
07/14/2009  05:33 AM             1,456 sch29.ldf
07/14/2009  05:33 AM             7,054 sch30.ldf
07/14/2009  05:33 AM            70,661 sch31.ldf
07/14/2009  05:33 AM             8,637 sch32.ldf
07/14/2009  05:33 AM             6,165 sch33.ldf
07/14/2009  05:33 AM            27,911 sch34.ldf
07/14/2009  05:33 AM             3,035 sch35.ldf
07/14/2009  05:33 AM             4,295 sch36.ldf
07/14/2009  05:33 AM            24,469 sch37.ldf
07/14/2009  05:33 AM               364 sch38.ldf
07/14/2009  05:33 AM             4,210 sch39.ldf
07/14/2009  05:33 AM            22,938 sch40.ldf
07/14/2009  05:33 AM             1,372 sch41.ldf
07/14/2009  05:33 AM            48,138 sch42.ldf
07/14/2009  05:33 AM            16,036 sch43.ldf
07/14/2009  05:33 AM             2,322 sch44.ldf
07/14/2009  05:33 AM            26,451 sch45.ldf
07/14/2009  05:33 AM               373 sch46.ldf
07/14/2009  05:33 AM               539 sch47.ldf
07/14/2009  05:33 AM         1,631,476 schema.ini
07/14/2009  05:33 AM            17,753 schupgrade.cat
              44 File(s)     11,175,854 bytes

 Directory of x:\support\adprep\en-us

06/17/2010  04:41 PM    <DIR>          .
06/17/2010  04:41 PM    <DIR>          ..
07/14/2009  05:33 AM            75,776 adprep.exe.mui
07/14/2009  05:33 AM            75,776 adprep32.exe.mui
               2 File(s)        151,552 bytes

     Total Files Listed:
              46 File(s)     11,327,406 bytes

Hope this helps.
1
 
ElRock619Commented:
I had the same problem with one of my servers and the problem was that the disk of Server 2008 R2 Sp1 was in a different language than my other domain controllers, you can check the language in the adprep folder there is a folder with the language en-us for english version.

Hope it helps for future issues like this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.