Cisco Router DSL config

I'm cofiguring a 2811 router for internet access through a dsl modem. the modem is doing the pppoe negotiation so the interface on the router is set for DHCP. attached is my current config. what do I need to get internet access working?
dtadminAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dtadminAuthor Commented:
Celebration2811#sh run
Building configuration...

Current configuration : 1191 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Celebration2811
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.30.39.2 10.30.39.20
!
ip dhcp pool Celebration
   network 10.30.39.0 255.255.255.0
   dns-server 10.1.200.108 10.1.200.16 10.1.200.45
   netbios-name-server 10.1.200.17
   default-router 10.30.39.1
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description outside DSL service
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description Internal Network
 ip address 10.30.39.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
no ip http server
no ip http secure-server
!
access-list 101 permit ip 10.30.39.0 0.0.0.255 10.1.0.0 0.0.255.255
access-list 110 permit ip 10.30.39.0 0.0.0.255 any
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

0
Istvan KalmarHead of IT Security Division Commented:
ip dhcp pool Celebration
 import all
0
Istvan KalmarHead of IT Security Division Commented:
and you need to add nat:

ip nat inside source list 110 interface fast 0/0 overload
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
t509Commented:

Additionally I wouldn´t recommend sending every DNS query to the external net, instead use the IOSes DNS-Server.

You can easily add DNS functionality to the router.

ip name-server 10.1.200.108
ip dns server
ip domain-lookup

ip dhcp pool Celebration
   network 10.30.39.0 255.255.255.0
   dns-server 10.30.39.1 <- The routers IP address itself
   netbios-name-server 10.1.200.17
   default-router 10.30.39.1

0
Istvan KalmarHead of IT Security Division Commented:
you need 'import all' if you want to use local DNS server......
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.